aboutsummaryrefslogtreecommitdiffstats
path: root/testing/ospd-ssh-keyscan/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/ospd-ssh-keyscan/APKBUILD')
-rw-r--r--testing/ospd-ssh-keyscan/APKBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/testing/ospd-ssh-keyscan/APKBUILD b/testing/ospd-ssh-keyscan/APKBUILD
new file mode 100644
index 0000000000..98b4847595
--- /dev/null
+++ b/testing/ospd-ssh-keyscan/APKBUILD
@@ -0,0 +1,34 @@
+# Contributor: Francesco Colista <fcolista@alpinelinux.org>
+# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
+pkgname=ospd-ssh-keyscan
+pkgver=1.0b1
+pkgrel=3
+_pkgid=2213
+pkgdesc="OSP server implementation to allow OpenVAS to scan ssh keys"
+url="http://openvas.org/"
+arch="noarch"
+license="GPL-2.0-or-later"
+depends="python3 ospd"
+makedepends="python3-dev py3-paramiko py3-setuptools"
+source="http://wald.intevation.org/frs/download.php/$_pkgid/$pkgname-$pkgver.tar.gz"
+builddir="$srcdir"/$pkgname-$pkgver
+
+build() {
+ cd "$builddir"
+ python3 setup.py build
+}
+
+check() {
+ cd "$builddir"
+ python3 setup.py check
+}
+
+package() {
+ cd "$builddir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+
+md5sums="e78c2f1c4c5fe316f98637535db8cbdf ospd-ssh-keyscan-1.0b1.tar.gz"
+sha256sums="27a73979722e5ec09579cbf8a37228fc0c2a452597e21547244104d29a98950c ospd-ssh-keyscan-1.0b1.tar.gz"
+sha512sums="510a084ff93e2c6283ef21ea4c439077b15c9ada92f48cd0876fca87d430a4479b5700b536d68322cbcde7a1cc5109993706fae4d29e9ee61a7cb927450e5262 ospd-ssh-keyscan-1.0b1.tar.gz"