aboutsummaryrefslogtreecommitdiffstats
path: root/testing/perl-cpan-changes/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/perl-cpan-changes/APKBUILD')
-rw-r--r--testing/perl-cpan-changes/APKBUILD18
1 files changed, 6 insertions, 12 deletions
diff --git a/testing/perl-cpan-changes/APKBUILD b/testing/perl-cpan-changes/APKBUILD
index c8adfb18f4..201927979a 100644
--- a/testing/perl-cpan-changes/APKBUILD
+++ b/testing/perl-cpan-changes/APKBUILD
@@ -4,36 +4,30 @@
pkgname=perl-cpan-changes
_pkgreal=CPAN-Changes
pkgver=0.400002
-pkgrel=0
+pkgrel=1
pkgdesc="Read and write Changes files"
-url="http://search.cpan.org/dist/CPAN-Changes/"
+url="https://metacpan.org/release/CPAN-Changes"
arch="noarch"
-license="GPL PerlArtistic"
-cpandepends=""
-cpanmakedepends=" "
-depends="$cpandepends"
-makedepends="perl-dev $cpanmakedepends"
+license="GPL-1.0-or-later OR Artistic-1.0-Perl"
+makedepends="perl-dev"
subpackages="$pkgname-doc"
source="http://search.cpan.org/CPAN/authors/id/H/HA/HAARG/$_pkgreal-$pkgver.tar.gz"
builddir="$srcdir/$_pkgreal-$pkgver"
prepare() {
- default_prepare || return 1
+ default_prepare
- cd "$builddir"
export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
}
build() {
- cd "$builddir"
export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
make && make test
}
package() {
- cd "$builddir"
- make DESTDIR="$pkgdir" install || return 1
+ make DESTDIR="$pkgdir" install
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}