aboutsummaryrefslogtreecommitdiffstats
path: root/testing/php7-diseval/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/php7-diseval/APKBUILD')
-rw-r--r--testing/php7-diseval/APKBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/testing/php7-diseval/APKBUILD b/testing/php7-diseval/APKBUILD
new file mode 100644
index 0000000000..0348aded35
--- /dev/null
+++ b/testing/php7-diseval/APKBUILD
@@ -0,0 +1,35 @@
+# Contributor: Stuart Cardall <developer@it-offshore.co.uk>
+# Maintainer: Stuart Cardall <developer@it-offshore.co.uk>
+pkgname=php7-diseval
+_pkgreal=diseval
+pkgver=0.1
+pkgrel=0
+pkgdesc="Disable eval in php7 (suhosin is not stable yet for php7)"
+url="https://github.com/mk-j/PHP_diseval_extension"
+arch="all"
+license="MIT"
+depends="php7-common"
+makedepends="php7-dev autoconf re2c"
+source="$pkgname-$pkgver.tar.gz::https://github.com/mk-j/PHP_diseval_extension/archive/$pkgver.tar.gz"
+builddir="$srcdir/PHP_diseval_extension-$pkgver/source"
+
+build() {
+ cd "$builddir"
+ phpize7
+ ./configure --prefix=/usr --with-php-config=php-config7
+ make
+}
+
+check() {
+ cd "$builddir"
+ make NO_INTERACTION=1 REPORT_EXIT_STATUS=1 test
+}
+
+package() {
+ cd "$builddir"
+ make INSTALL_ROOT="$pkgdir" install
+ install -d "$pkgdir"/etc/php7/conf.d
+ echo "extension=$_pkgreal.so" > "$pkgdir"/etc/php7/conf.d/$_pkgreal.ini
+}
+
+sha512sums="14cddbebe1cb1bd114dd6f1ea122b262340ed5894178d7332f4168753c07670925fbbf9bae444a726b8d1e1cf28fc8f2e45d511e0523ac30ab37a1fb9f758c8e php7-diseval-0.1.tar.gz"