aboutsummaryrefslogtreecommitdiffstats
path: root/testing/php7-mustache/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/php7-mustache/APKBUILD')
-rw-r--r--testing/php7-mustache/APKBUILD17
1 files changed, 8 insertions, 9 deletions
diff --git a/testing/php7-mustache/APKBUILD b/testing/php7-mustache/APKBUILD
index ea1bcdab98..fa096cf980 100644
--- a/testing/php7-mustache/APKBUILD
+++ b/testing/php7-mustache/APKBUILD
@@ -1,21 +1,20 @@
# Maintainer: Renoir Boulanger <hello@renoirboulanger.com>
-
-pkgname=php7-mustache
-_phpext=mustache
+pkgname="php7-mustache"
+_phpext="mustache"
pkgver=0.7.4
-pkgrel=0
+pkgrel=1
pkgdesc="PHP 7 PECL extension: C++ implementation of Mustache"
giturl="https://github.com/jbboehr/php-mustache.git"
url="https://github.com/jbboehr/php-mustache"
-arch=all
-license=MIT
-depends=libmustache
+arch="all"
+license="MIT"
+depends="libmustache"
makedepends="php7-dev autoconf"
# Look at commit ref for spec/ folder at https://github.com/jbboehr/mustache-spec
_mustachespec_gitrev=72233f3ffda9e33915fd3022d0a9ebbcce265acd
_pkg_filename=php-mustache-$pkgver
source="php-mustache-$pkgver.tar.gz::https://github.com/jbboehr/php-mustache/archive/v$pkgver.tar.gz
- mustache-spec-$_mustachespec_gitrev.tar.gz::https://github.com/jbboehr/mustache-spec/archive/$_mustachespec_gitrev.tar.gz"
+ mustache-spec-$_mustachespec_gitrev.tar.gz::https://github.com/jbboehr/mustache-spec/archive/$_mustachespec_gitrev.tar.gz"
builddir="$srcdir/$_pkg_filename/"
prepare() {
@@ -39,7 +38,7 @@ build() {
check() {
cd "$builddir"
- make test < /dev/null
+ make NO_INTERACTION=1 REPORT_EXIT_STATUS=1 test
}
package() {