aboutsummaryrefslogtreecommitdiffstats
path: root/testing/php7-tideways_xhprof/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/php7-tideways_xhprof/APKBUILD')
-rw-r--r--testing/php7-tideways_xhprof/APKBUILD14
1 files changed, 6 insertions, 8 deletions
diff --git a/testing/php7-tideways_xhprof/APKBUILD b/testing/php7-tideways_xhprof/APKBUILD
index 06cd28ed8b..a9944b0b64 100644
--- a/testing/php7-tideways_xhprof/APKBUILD
+++ b/testing/php7-tideways_xhprof/APKBUILD
@@ -5,19 +5,19 @@ _pkgext=tideways_xhprof
_pkgreal=php-xhprof-extension
pkgver=5.0_beta3
_pkgver=${pkgver/_/-}
-pkgrel=2
+pkgrel=3
pkgdesc="Modern XHProf compatible Profiler for PHP 7"
url="http://tideways.io"
-arch="all !armhf !armv7 !aarch64 !s390x" # fails to build
+arch="all"
license="Apache-2.0"
depends="php7"
makedepends="php7-dev autoconf"
source="$pkgname-$pkgver.tar.gz::https://github.com/tideways/php-xhprof-extension/archive/v$_pkgver.tar.gz
- 73.patch"
+ 73.patch
+ 74.patch"
builddir="$srcdir/$_pkgreal-$_pkgver"
build() {
- cd "$builddir"
phpize7
./configure --prefix=/usr \
--with-php-config=/usr/bin/php-config7
@@ -25,13 +25,10 @@ build() {
}
check() {
- cd "$builddir"
make NO_INTERACTION=1 REPORT_EXIT_STATUS=1 test
}
package() {
- cd "$builddir"
-
make INSTALL_ROOT="$pkgdir/" install
install -d "$pkgdir"/etc/php7/conf.d
@@ -39,4 +36,5 @@ package() {
}
sha512sums="5b682ed8cda21236c54c3161645620ba06f14478fcf1b45684788b742e47d63419b3e3f74da7d3e376ce5fafeb215ed40d080aaac0c2a8799315f83c877e3110 php7-tideways_xhprof-5.0_beta3.tar.gz
-2dfee43f28d7872f08688b354b25c177bb16a5474d2df999be0155362998841c1afa0b5adaf41d016be8c9e50f669d0f69bd56891d4e1e4ef999b9ea2118dfa8 73.patch"
+2dfee43f28d7872f08688b354b25c177bb16a5474d2df999be0155362998841c1afa0b5adaf41d016be8c9e50f669d0f69bd56891d4e1e4ef999b9ea2118dfa8 73.patch
+202c2f343d5b52479407b7e74e3fb6e9c7db7886fc1e72818ce9f00c4fab1934f1dee94829221a354caaed63299b9d0ca6c477dae9b3aeb5d68381abdcb6ba78 74.patch"