aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py-junit-xml/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py-junit-xml/APKBUILD')
-rw-r--r--testing/py-junit-xml/APKBUILD13
1 files changed, 10 insertions, 3 deletions
diff --git a/testing/py-junit-xml/APKBUILD b/testing/py-junit-xml/APKBUILD
index ce71a139bc..ff0f78bb6d 100644
--- a/testing/py-junit-xml/APKBUILD
+++ b/testing/py-junit-xml/APKBUILD
@@ -2,17 +2,23 @@
pkgname=py-junit-xml
_pkgname=${pkgname/py-}
pkgver=1.8
-pkgrel=0
+pkgrel=1
pkgdesc="Creates JUnit XML test result documents that can be read by tools such as Jenkins"
url="https://pypi.python.org/pypi/junit-xml"
arch="noarch"
license="MIT"
depends=""
makedepends="python2-dev python3-dev py2-setuptools"
+checkdepends="py-six"
subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
-source="https://pypi.python.org/packages/a6/2a/f8d5aab80bb31fcc789d0f2b34b49f08bd6121cd8798d2e37f416df2b9f8/junit-xml-$pkgver.tar.gz"
+source="https://pypi.python.org/packages/a6/2a/f8d5aab80bb31fcc789d0f2b34b49f08bd6121cd8798d2e37f416df2b9f8/junit-xml-$pkgver.tar.gz
+ disable_failing_test.patch"
builddir="$srcdir"/$_pkgname-$pkgver
+prepare() {
+ default_prepare
+}
+
build() {
cd "$builddir"
python2 setup.py build
@@ -49,4 +55,5 @@ _py() {
cd "$builddir"
$python setup.py install --prefix=/usr --root="$subpkgdir"
}
-sha512sums="8fcef94ea73a77ad597bb3280578f0fea86573b779eb4aea1e458e55f1866637a7b43aa04502a65ecb1f2a7403cc61a76ccd35feb4b69eeb6fdc8352914d61a4 junit-xml-1.8.tar.gz"
+sha512sums="8fcef94ea73a77ad597bb3280578f0fea86573b779eb4aea1e458e55f1866637a7b43aa04502a65ecb1f2a7403cc61a76ccd35feb4b69eeb6fdc8352914d61a4 junit-xml-1.8.tar.gz
+af01b010c4272ebb3fedcbefe5d19c842976765575d35c3649ffb1dfa2313ea9638c6eef2e489651f164e1398b5f12954f15516ac339ef99a49a5d32120f5c4a disable_failing_test.patch"