aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py-yaml/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py-yaml/APKBUILD')
-rw-r--r--testing/py-yaml/APKBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/testing/py-yaml/APKBUILD b/testing/py-yaml/APKBUILD
new file mode 100644
index 0000000000..29e0f3e62c
--- /dev/null
+++ b/testing/py-yaml/APKBUILD
@@ -0,0 +1,29 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py-yaml
+_pkgname=PyYAML
+pkgver=3.10
+pkgrel=0
+pkgdesc="Python bindings for YAML"
+url="http://pyyaml.org"
+arch="all"
+license="MIT"
+depends=
+depends_dev=
+makedepends="libyaml-dev python-dev"
+install=""
+subpackages=""
+source="http://pyyaml.org/download/pyyaml/$_pkgname-$pkgver.tar.gz"
+_builddir="$srcdir"/$_pkgname-$pkgver
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="74c94a383886519e9e7b3dd1ee540247 PyYAML-3.10.tar.gz"