aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-amqp
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py3-amqp')
-rw-r--r--testing/py3-amqp/APKBUILD64
1 files changed, 64 insertions, 0 deletions
diff --git a/testing/py3-amqp/APKBUILD b/testing/py3-amqp/APKBUILD
new file mode 100644
index 0000000000..b9fa1f2216
--- /dev/null
+++ b/testing/py3-amqp/APKBUILD
@@ -0,0 +1,64 @@
+# Maintainer: Drew DeVault <sir@cmpwn.com>
+pkgname=py-amqp
+_pyname=amqp
+pkgver=2.4.2
+pkgrel=1
+pkgdesc="an AMQP implementation"
+url="https://pypi.python.org/pypi/amqp/"
+arch="noarch"
+license="BSD"
+subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
+makedepends="python2 python3 py2-setuptools py3-setuptools"
+checkdepends="
+ py2-vine py3-vine py2-case py3-case py2-nose py3-nose py2-mock py3-mock
+ py2-unittest2
+"
+_pypiprefix="${_pyname%${_pyname#?}}"
+source="https://files.pythonhosted.org/packages/source/$_pypiprefix/$_pyname/$_pyname-$pkgver.tar.gz"
+builddir=$srcdir/$_pyname-$pkgver
+# requires a running rabbitmq sever, which is more complicated than it sounds
+options="!check"
+
+prepare() {
+ cd "$builddir"
+ sed -i requirements/test.txt -e 's/pytest-sugar.*//g'
+ cp -r "$builddir" "$builddir"-py2
+}
+
+build() {
+ cd "$builddir"
+ python3 setup.py build
+ cd "$builddir"-py2
+ python2 setup.py build
+}
+
+check() {
+ cd "$builddir"
+ python3 setup.py test
+ cd "$builddir"-py2
+ python2 setup.py test
+}
+
+package() {
+ mkdir -p "$pkgdir"
+}
+
+_py2() {
+ cd "$builddir"-py2
+ _py python2
+}
+
+_py3() {
+ cd "$builddir"
+ _py python3
+ }
+
+_py() {
+ _python="$1"
+ pkgdesc="$pkgdesc (for $_python)"
+ depends="$depends $_python"
+ install_if="$pkgname=$pkgver-r$pkgrel $_python"
+ $_python setup.py install --prefix=/usr --root="$subpkgdir"
+}
+
+sha512sums="dba880c07ee8b503e02f11ea5804f559ac2eb85717118d796558b1890032482babd15930af78f9d11b77530d496fce3ba8c8579eec71ce5a3f76b8d8a181af34 amqp-2.4.2.tar.gz"