aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-ansi2html/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py3-ansi2html/APKBUILD')
-rw-r--r--testing/py3-ansi2html/APKBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/testing/py3-ansi2html/APKBUILD b/testing/py3-ansi2html/APKBUILD
new file mode 100644
index 0000000000..b9f6db1b77
--- /dev/null
+++ b/testing/py3-ansi2html/APKBUILD
@@ -0,0 +1,32 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py3-ansi2html
+_pkgname=ansi2html
+pkgver=1.3.0
+pkgrel=0
+pkgdesc="Convert text with ANSI color codes to HTML"
+url="http://github.com/ralphbean/ansi2html/"
+arch="noarch"
+license="GPL-3.0-or-later"
+provides="py-ansi2html" # for backwards compatibility
+replaces="py-ansi2html=$pkgver-r$pkgrel" # for backwards compatibility
+depends="python3 py3-setuptools py3-six"
+depends_dev=""
+makedepends="python3-dev"
+install=""
+subpackages=""
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+
+builddir="$srcdir"/$_pkgname-$pkgver
+
+build() {
+ cd "$builddir"
+ python3 setup.py build || return 1
+}
+
+package() {
+ cd "$builddir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+sha512sums="73d1b3431e22146c4fe18fef4b05413231d79d627c396d67528d0aa1ab07a7ef4bcfeff56829b85d9fe9ad508599b782318911f7b10d6b9a1bc98780e31389d7 ansi2html-1.3.0.tar.gz"