aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-ask/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py3-ask/APKBUILD')
-rw-r--r--testing/py3-ask/APKBUILD22
1 files changed, 10 insertions, 12 deletions
diff --git a/testing/py3-ask/APKBUILD b/testing/py3-ask/APKBUILD
index 6e4ae0bf5e..9422add285 100644
--- a/testing/py3-ask/APKBUILD
+++ b/testing/py3-ask/APKBUILD
@@ -1,30 +1,28 @@
# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
-pkgname=py-ask
+pkgname=py3-ask
_pkgname=ask
pkgver=0.0.8
-pkgrel=0
+pkgrel=1
pkgdesc="An easy input validation for Python"
+options="!check" # No testsuite
url="https://github.com/chive/ask"
arch="noarch"
license="MIT"
-depends="python2"
-depends_dev=""
-makedepends="python2-dev py-setuptools"
-install=""
-subpackages=""
+depends="python3"
+makedepends="py3-setuptools"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
-
builddir="$srcdir/$_pkgname-$pkgver"
+replaces="py-ask" # Backwards compatibility
+provides="py-ask=$pkgver-r$pkgrel" # Backwards compatibility
+
build() {
- cd "$builddir"
- python2 setup.py build
+ python3 setup.py build
}
package() {
- cd "$builddir"
- python2 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
}
sha512sums="8258349066a4f57d1a5e7a136cca8330e662e135ac366b905327e9c3535ec1a949865cf20e1332d9f8a22d06c76474f86cdbd11e52bf7c002e87a3f3654ded60 ask-0.0.8.tar.gz"