aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-dexml/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py3-dexml/APKBUILD')
-rw-r--r--testing/py3-dexml/APKBUILD25
1 files changed, 5 insertions, 20 deletions
diff --git a/testing/py3-dexml/APKBUILD b/testing/py3-dexml/APKBUILD
index 70af28c1cf..e5b6226179 100644
--- a/testing/py3-dexml/APKBUILD
+++ b/testing/py3-dexml/APKBUILD
@@ -11,33 +11,18 @@ license="MIT"
provides="py-dexml" # for backwards compatibility
replaces="py-dexml=$pkgver-r$pkgrel" # for backwards compatibility
depends="python3"
-depends_dev=""
makedepends="python3-dev py3-setuptools"
-install=""
-subpackages=""
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
-
-_builddir="$srcdir"/$_pkgname-$pkgver
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
+builddir="$srcdir"/$_pkgname-$pkgver
build() {
- cd "$_builddir"
- python3 setup.py build || return 1
+ cd "$builddir"
+ python3 setup.py build
}
package() {
- cd "$_builddir"
- python3 setup.py install --prefix=/usr --root="$pkgdir" || return 1
+ cd "$builddir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
}
-md5sums="7f7bbb66cdceb38adbc9092a9a159d87 dexml-0.5.1.tar.gz"
-sha256sums="6ba83883ead5cc74ce8198daecc657b60bf9cdb3887b484a92dcde55c10e2cdf dexml-0.5.1.tar.gz"
sha512sums="b8ac2b9f875ac7cf699eb9ee17adb8678ed8d4a796130bbb60f05431207adb68f490b7a7a41600acbc16a3cc08d55f22d91a13e53fe3d835a322709ee3446c9f dexml-0.5.1.tar.gz"