aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-html/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py3-html/APKBUILD')
-rw-r--r--testing/py3-html/APKBUILD45
1 files changed, 19 insertions, 26 deletions
diff --git a/testing/py3-html/APKBUILD b/testing/py3-html/APKBUILD
index 48e77d0f7d..cef18c9b72 100644
--- a/testing/py3-html/APKBUILD
+++ b/testing/py3-html/APKBUILD
@@ -1,41 +1,34 @@
# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
-pkgname=py-html
+pkgname=py3-html
_pkgname=html
pkgver=1.16
-pkgrel=0
+pkgrel=1
pkgdesc="A Python HTML, XHTML, and XML generation module"
url="http://pypi.python.org/pypi/html"
arch="noarch"
-license="BSD"
-depends="python2"
-depends_dev=""
-makedepends="python2-dev py-setuptools"
-install=""
-subpackages=""
-source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+license="MIT"
+depends="python3"
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz
+ fix-install-py3.patch
+ "
-_builddir="$srcdir"/$_pkgname-$pkgver
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
+replaces="py-html" # Backwards compat
+provides="py-html=$pkgver-r$pkgrel" # Backwards compat
+
+builddir="$srcdir"/$_pkgname-$pkgver
build() {
- cd "$_builddir"
- python2 setup.py build || return 1
+ python3 setup.py build
+}
+
+check() {
+ python3 -m html
}
package() {
- cd "$_builddir"
- python2 setup.py install --prefix=/usr --root="$pkgdir" || return 1
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
}
-md5sums="39b9db7cdcc84607828be021172d441f html-1.16.tar.gz"
-sha256sums="ebc768f23b54a71350d731a75f2ef3a4a4dbdad9ae68d58b527664b66088e456 html-1.16.tar.gz"
-sha512sums="fe2329775bc9154aafe2411adb893ce443d3e0875cfa0efa9a722c068578713d3cc123fc62e732215766b3bf7371777a173969100f3025b9f9c99b504482ea39 html-1.16.tar.gz"
+sha512sums="fe2329775bc9154aafe2411adb893ce443d3e0875cfa0efa9a722c068578713d3cc123fc62e732215766b3bf7371777a173969100f3025b9f9c99b504482ea39 html-1.16.tar.gz
+98d5d4b6e0ff941f82de2a6f61ac1b8e0866195a28519957132c094c98bf8cf844528ba2f30e4996bc023862ab5c095695317034c908c634456d48d10bb2c041 fix-install-py3.patch"