aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-jsonpatch/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py3-jsonpatch/APKBUILD')
-rw-r--r--testing/py3-jsonpatch/APKBUILD53
1 files changed, 53 insertions, 0 deletions
diff --git a/testing/py3-jsonpatch/APKBUILD b/testing/py3-jsonpatch/APKBUILD
new file mode 100644
index 0000000000..12d51aedc2
--- /dev/null
+++ b/testing/py3-jsonpatch/APKBUILD
@@ -0,0 +1,53 @@
+# Contributor: Matt Dainty <matt+alpine@bodgit-n-scarper.com>
+# Maintainer: TBK <alpine@jjtc.eu>
+pkgname=py-jsonpatch
+_pkgname=${pkgname#py-}
+pkgver=1.23
+pkgrel=1
+pkgdesc="Apply JSON-Patches (RFC 6902)"
+url="https://github.com/stefankoegl/python-json-patch"
+arch="noarch"
+license="BSD-3-Clause"
+depends="py-jsonpointer"
+makedepends="python2-dev python3-dev py-setuptools"
+subpackages="py3-$_pkgname:_py3 py2-$_pkgname:_py2"
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir"/$_pkgname-$pkgver
+
+build() {
+ cd "$builddir"
+ python2 setup.py build
+ python3 setup.py build
+}
+
+check() {
+ cd "$builddir"
+ python2 setup.py test
+ python3 setup.py test
+}
+
+package() {
+ mkdir -p "$pkgdir"
+}
+
+_py() {
+ local python="$1"
+ pkgdesc="$pkgdesc (for $python)"
+ depends="$depends $python"
+ install_if="$pkgname=$pkgver-r$pkgrel $python"
+
+ cd "$builddir"
+ $python setup.py install --prefix=/usr --root="$subpkgdir"
+}
+
+_py2() {
+ replaces="$pkgname"
+ depends="${depends//py-/py2-}"
+ _py python2
+}
+
+_py3() {
+ depends="${depends//py-/py3-}"
+ _py python3
+}
+sha512sums="da612fc043e351087fbda26cd5686743107dafca1223e784626c39113dfb4770647db1420e9ab9eee93d12c608a6e0812f0825229ab092962cfb390b6b1795ed jsonpatch-1.23.tar.gz"