aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-pathspec/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py3-pathspec/APKBUILD')
-rw-r--r--testing/py3-pathspec/APKBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/testing/py3-pathspec/APKBUILD b/testing/py3-pathspec/APKBUILD
new file mode 100644
index 0000000000..65c7ba165b
--- /dev/null
+++ b/testing/py3-pathspec/APKBUILD
@@ -0,0 +1,28 @@
+# Contributor: Michał Polański <michal@polanski.me>
+# Maintainer: Michał Polański <michal@polanski.me>
+pkgname=py3-pathspec
+_pkgname=pathspec
+pkgver=0.7.0
+pkgrel=0
+pkgdesc="Utility library for gitignore style pattern matching of file paths"
+url="https://github.com/cpburnz/python-path-specification"
+arch="noarch"
+license="MPL-2.0"
+depends="python3"
+makedepends="py3-setuptools"
+source="https://files.pythonhosted.org/packages/source/p/pathspec/pathspec-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgname-$pkgver"
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ python3 -m unittest discover pathspec/tests
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir" --skip-build
+}
+
+sha512sums="3171d39405eb586945261b11781b966e0771649dd7caa8f8a5bbd26223a37931c17bd50a4706d603a637a10460e9b3730c21f0eff7dc92d7e73ae570641a900c pathspec-0.7.0.tar.gz"