aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-pycosat/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py3-pycosat/APKBUILD')
-rw-r--r--testing/py3-pycosat/APKBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/testing/py3-pycosat/APKBUILD b/testing/py3-pycosat/APKBUILD
new file mode 100644
index 0000000000..55160f2848
--- /dev/null
+++ b/testing/py3-pycosat/APKBUILD
@@ -0,0 +1,30 @@
+# Contributor: Jakub Jirutka <jakub@jirutka.cz>
+# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
+pkgname=py3-pycosat
+_pkgname=pycosat
+pkgver=0.6.3
+pkgrel=0
+pkgdesc="Python bindings to picosat (a SAT solver)"
+url="https://github.com/ContinuumIO/pycosat"
+arch="all"
+license="MIT"
+makedepends="python3-dev"
+source="https://github.com/ContinuumIO/pycosat/archive/$pkgver/$_pkgname-$pkgver.tar.gz
+ musl-compat.patch
+ "
+builddir="$srcdir/$_pkgname-$pkgver"
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ PYTHONPATH="./build/lib.linux-x86_64-3.6" python3 test_pycosat.py
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="6163f9879d4ed98486f36990f0134db0a9b6096a8507312a1013d707b0dcb7e963845a5959c601f672a53a5db8c80b63d3184a0ef906b2ec563ca1a4c63850fa pycosat-0.6.3.tar.gz
+57fae28c1d9f9e5fd2c8800ec664e0c43b04935f540ab2576fd660cb902e62edcc727aab3f7dacd33db1e775d49ebdffc24fbe4a4136ec5e3ea54cc5c37b2cef musl-compat.patch"