aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-tldextract/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py3-tldextract/APKBUILD')
-rw-r--r--testing/py3-tldextract/APKBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/testing/py3-tldextract/APKBUILD b/testing/py3-tldextract/APKBUILD
new file mode 100644
index 0000000000..811fa342a4
--- /dev/null
+++ b/testing/py3-tldextract/APKBUILD
@@ -0,0 +1,28 @@
+# Contributor: Galen Abell <galen@galenabell.com>
+# Maintainer: Galen Abell <galen@galenabell.com>
+pkgname="py3-tldextract"
+_pyname="tldextract"
+pkgver="2.2.2"
+pkgrel=0
+pkgdesc="Accurately separate the TLD from the registered domain and subdomains of a URL"
+url="https://github.com/john-kurkowski/tldextract"
+arch="noarch"
+license="BSD-3-Clause"
+depends="python3"
+makedepends="py3-setuptools"
+checkdepends="py3-pytest py3-responses"
+source="$_pyname-$pkgver.tar.gz::https://github.com/john-kurkowski/tldextract/archive/$pkgver.tar.gz"
+builddir="$srcdir/$_pyname-$pkgver"
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ python3 setup.py test
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+sha512sums="d8bd876910cb5ac2d66286eac965cc726f1bd786469da35bff1e1da32664b1c21eeb0c8f29a77f1393791285c1fc40cdf95b15d0c9d03ef77e91587bebf5b20b tldextract-2.2.2.tar.gz"