aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-xlwt/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py3-xlwt/APKBUILD')
-rw-r--r--testing/py3-xlwt/APKBUILD6
1 files changed, 3 insertions, 3 deletions
diff --git a/testing/py3-xlwt/APKBUILD b/testing/py3-xlwt/APKBUILD
index 6fb96bb770..d504e99b89 100644
--- a/testing/py3-xlwt/APKBUILD
+++ b/testing/py3-xlwt/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
pkgname=py3-xlwt
_pkgname=xlwt
-pkgver=0.7.5
+pkgver=1.3.0
pkgrel=0
pkgdesc="A library to create spreadsheet files"
url="https://pypi.org/project/xlwt"
@@ -10,7 +10,7 @@ arch="noarch"
license="BSD-3-Clause BSD-4-Clause LGPL-2.1-or-later"
provides="py-xlwt" # for backwards compatibility
replaces="py-xlwt=$pkgver-r$pkgrel" # for backwards compatibility
-depends="python3"
+depends="py3-six python3"
makedepends="py3-setuptools python3-dev"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir"/$_pkgname-$pkgver
@@ -25,4 +25,4 @@ package() {
python3 setup.py install --prefix=/usr --root="$pkgdir"
}
-sha512sums="d385c36c80002998891dd93d4ebcdd962239463ee089965961d3b8955d4783bbcdec96920891a252ee6cb076eab6b13ffad83e7758c179dcbc684e82fa8dfe35 xlwt-0.7.5.tar.gz"
+sha512sums="e09c515bda7edadb9624b842796a537316c1e2e06f3e74aca5440a5797dbc259036539fd64ea61648a30894f4091d3be829411d36e6170894980728c798c5963 xlwt-1.3.0.tar.gz"