aboutsummaryrefslogtreecommitdiffstats
path: root/testing/quickjs/00-makefile.patch
diff options
context:
space:
mode:
Diffstat (limited to 'testing/quickjs/00-makefile.patch')
-rw-r--r--testing/quickjs/00-makefile.patch51
1 files changed, 10 insertions, 41 deletions
diff --git a/testing/quickjs/00-makefile.patch b/testing/quickjs/00-makefile.patch
index fc9cb15bfc..bc0a2a911c 100644
--- a/testing/quickjs/00-makefile.patch
+++ b/testing/quickjs/00-makefile.patch
@@ -6,20 +6,16 @@ Remove When: The default Makefile doesn't enforce 32 bit binaries and allows for
3. Allow for static linking.
--- a/Makefile 2019-09-04 19:14:04.134679886 -0400
+++ b/Makefile 2019-09-04 19:15:42.761338716 -0400
-@@ -32,9 +32,8 @@
- # consider warnings as errors (for development)
+@@ -33,6 +33,7 @@
#CONFIG_WERROR=y
--
--ifndef CONFIG_WIN32
# force 32 bit build for some utilities
--CONFIG_M32=y
--endif
-+#CONFIG_M32=y
+ #CONFIG_M32=y
+#CONFIG_STATIC=y
-+
+
ifdef CONFIG_DARWIN
# use clang instead of gcc
-@@ -100,4 +99,7 @@
+@@ -105,6 +106,9 @@
+ CFLAGS_OPT=$(CFLAGS) -O2
CFLAGS_NOLTO:=$(CFLAGS_OPT)
LDFLAGS=-g
+ifdef CONFIG_STATIC
@@ -27,7 +23,9 @@ Remove When: The default Makefile doesn't enforce 32 bit binaries and allows for
+endif
ifdef CONFIG_LTO
CFLAGS_SMALL+=-flto
-@@ -113,9 +115,9 @@
+ CFLAGS_OPT+=-flto
+@@ -118,11 +122,11 @@
+ CFLAGS+=-fsanitize=address
LDFLAGS+=-fsanitize=address
endif
-ifdef CONFIG_WIN32
@@ -39,34 +37,5 @@ Remove When: The default Makefile doesn't enforce 32 bit binaries and allows for
endif
+endif
- PROGS=qjs$(EXE) qjsbn$(EXE) qjsc qjsbnc run-test262 run-test262-bn
-@@ -149,5 +151,5 @@
- QJSBN_OBJS=$(OBJDIR)/qjs.bn.o $(OBJDIR)/repl-bn.bn.o $(OBJDIR)/qjscalc.bn.o $(QJSBN_LIB_OBJS)
-
--LIBS=-lm
-+LIBS=-lm -pthread
- ifndef CONFIG_WIN32
- LIBS+=-ldl
-@@ -235,17 +237,17 @@
-
- run-test262: $(OBJDIR)/run-test262.o $(QJS_LIB_OBJS)
-- $(CC) $(LDFLAGS) -o $@ $^ $(LIBS) -lpthread
-+ $(CC) $(LDFLAGS) -o $@ $^ $(LIBS)
-
- run-test262-bn: $(OBJDIR)/run-test262.bn.o $(QJSBN_LIB_OBJS)
-- $(CC) $(LDFLAGS) -o $@ $^ $(LIBS) -lpthread
-+ $(CC) $(LDFLAGS) -o $@ $^ $(LIBS)
-
- run-test262-debug: $(patsubst %.o, %.debug.o, $(OBJDIR)/run-test262.o $(QJS_LIB_OBJS))
-- $(CC) $(LDFLAGS) -o $@ $^ $(LIBS) -lpthread
-+ $(CC) $(LDFLAGS) -o $@ $^ $(LIBS)
-
- run-test262-32: $(patsubst %.o, %.m32.o, $(OBJDIR)/run-test262.o $(QJS_LIB_OBJS))
-- $(CC) -m32 $(LDFLAGS) -o $@ $^ $(LIBS) -lpthread
-+ $(CC) -m32 $(LDFLAGS) -o $@ $^ $(LIBS)
-
- run-test262-bn32: $(patsubst %.o, %.m32.o, $(OBJDIR)/run-test262.bn.o $(QJSBN_LIB_OBJS))
-- $(CC) -m32 $(LDFLAGS) -o $@ $^ $(LIBS) -lpthread
-+ $(CC) -m32 $(LDFLAGS) -o $@ $^ $(LIBS)
-
- # object suffix order: bn, nolto, [m32|m32s]
+ PROGS=qjs$(EXE) qjsc$(EXE) run-test262
+ ifneq ($(CROSS_PREFIX),)