aboutsummaryrefslogtreecommitdiffstats
path: root/testing/rav1e
diff options
context:
space:
mode:
Diffstat (limited to 'testing/rav1e')
-rw-r--r--testing/rav1e/APKBUILD4
1 files changed, 4 insertions, 0 deletions
diff --git a/testing/rav1e/APKBUILD b/testing/rav1e/APKBUILD
index 153a2cc4d6..e38307b586 100644
--- a/testing/rav1e/APKBUILD
+++ b/testing/rav1e/APKBUILD
@@ -12,6 +12,10 @@ makedepends="cargo nasm"
subpackages="$pkgname-doc $pkgname-libs"
source="$pkgname-$pkgver.tar.gz::https://github.com/xiph/rav1e/archive/v$pkgver.tar.gz"
+case "$CARCH" in
+ x86) CFLAGS="$CFLAGS -fno-stack-protector" ;;
+esac
+
prepare() {
RUSTFLAGS="-C opt-level=0" \
cargo install --force --root "$srcdir" cargo-c