aboutsummaryrefslogtreecommitdiffstats
path: root/testing/rocksdb/10-support-busybox-install.patch
diff options
context:
space:
mode:
Diffstat (limited to 'testing/rocksdb/10-support-busybox-install.patch')
-rw-r--r--testing/rocksdb/10-support-busybox-install.patch20
1 files changed, 20 insertions, 0 deletions
diff --git a/testing/rocksdb/10-support-busybox-install.patch b/testing/rocksdb/10-support-busybox-install.patch
new file mode 100644
index 0000000000..8974dfa9a0
--- /dev/null
+++ b/testing/rocksdb/10-support-busybox-install.patch
@@ -0,0 +1,20 @@
+--- a/Makefile
++++ b/Makefile
+@@ -996,14 +996,14 @@ install-headers:
+ install -d $(INSTALL_PATH)/$$header_dir; \
+ done
+ for header in `find "include/rocksdb" -type f -name *.h`; do \
+- install -C -m 644 $$header $(INSTALL_PATH)/$$header; \
++ install -c -m 644 $$header $(INSTALL_PATH)/$$header; \
+ done
+
+ install-static: install-headers $(LIBRARY)
+- install -C -m 755 $(LIBRARY) $(INSTALL_PATH)/lib
++ install -c -m 755 $(LIBRARY) $(INSTALL_PATH)/lib
+
+ install-shared: install-headers $(SHARED4)
+- install -C -m 755 $(SHARED4) $(INSTALL_PATH)/lib && \
++ install -c -m 755 $(SHARED4) $(INSTALL_PATH)/lib && \
+ ln -fs $(SHARED4) $(INSTALL_PATH)/lib/$(SHARED3) && \
+ ln -fs $(SHARED4) $(INSTALL_PATH)/lib/$(SHARED2) && \
+ ln -fs $(SHARED4) $(INSTALL_PATH)/lib/$(SHARED1)