aboutsummaryrefslogtreecommitdiffstats
path: root/testing/rpcbind/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/rpcbind/APKBUILD')
-rw-r--r--testing/rpcbind/APKBUILD42
1 files changed, 42 insertions, 0 deletions
diff --git a/testing/rpcbind/APKBUILD b/testing/rpcbind/APKBUILD
new file mode 100644
index 0000000000..3574ffece0
--- /dev/null
+++ b/testing/rpcbind/APKBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=rpcbind
+pkgver=0.2.0
+pkgrel=0
+pkgdesc="portmap replacement which supports RPC over various protocols"
+url="http://rpcbind.sourceforge.net"
+license="custom"
+depends=
+makedepends="libtirpc-dev"
+subpackages="$pkgname-doc"
+source="http://downloads.sourceforge.net/sourceforge/$pkgname/$pkgname-$pkgver.tar.bz2
+ 0001-uclibc-nss.patch
+ 0002-uclibc-rpcsvc-defines.patch
+ rpcbind.initd
+ rpcbind.confd"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+prepare() {
+ cd "$_builddir"
+ for i in "$srcdir"/*.patch; do
+ patch -p1 -i "$i" || return 1
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr --bindir=/sbin
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ install -Dm755 "$srcdir"/rpcbind.initd "$pkgdir"/etc/init.d/rpcbind
+ install -Dm644 "$srcdir"/rpcbind.confd "$pkgdir"/etc/conf.d/rpcbind
+ install -D -m644 COPYING "$pkgdir"/usr/share/licenses/rpcbind/COPYING
+}
+md5sums="1a77ddb1aaea8099ab19c351eeb26316 rpcbind-0.2.0.tar.bz2
+6d9718d8bdab633ef7cf83225aaed367 0001-uclibc-nss.patch
+944234c5ef6902d25bd6dfc95f979ed6 0002-uclibc-rpcsvc-defines.patch
+381a2722c69b4597af532381f1ffeae0 rpcbind.initd
+1ad5c8dcf432c8f23ba740f4c32a7c60 rpcbind.confd"