aboutsummaryrefslogtreecommitdiffstats
path: root/testing/thermald
diff options
context:
space:
mode:
Diffstat (limited to 'testing/thermald')
-rw-r--r--testing/thermald/APKBUILD2
-rw-r--r--testing/thermald/ppc64le.patch8
2 files changed, 5 insertions, 5 deletions
diff --git a/testing/thermald/APKBUILD b/testing/thermald/APKBUILD
index 8e9e32bafd..549a3f0196 100644
--- a/testing/thermald/APKBUILD
+++ b/testing/thermald/APKBUILD
@@ -44,4 +44,4 @@ package() {
sha512sums="71fa6e9fc2f55623ed0acdb65f9699d5ea2c89c4092546a73d53ac3ea3ca0a5c60f3360c8bef0af9daeeecfe9a20411d9e4d25bc1d89349cfe83ebb03ba387a8 thermald-1.9.tar.gz
ea8964b15fdebc2fb59e93c15b813b93691c2ba01689ac6080f1308a3063b23cba56b4539ccae87575689036f74300a1c22c9b0e77d4ecef9bc08198d7fe4892 thermald.initd
ea72002dcdfa907964f2ffc28947d8b2b536a93876d65872085aa9ebf2bdb549fae9c43412d74590ad88d2d71c48067726cc755630c41e30d77eb9c0c56d7308 no-werror.patch
-0700af8160d6953e5144feba252592aaa03d8aa0a3be51e90fcab31924d728998cffd970bba9f4fc9d64819cb050fe66b99d6490c077b4a8cc152926964c90e0 ppc64le.patch"
+21168079e65253a1f4b762a1d4114400ff77d658f2f0ad4374f964033b9d8a2ec58ba8e65ca949add02945ba682ce8ff6e65ff27bfac6fa21e2d513c3898af0e ppc64le.patch"
diff --git a/testing/thermald/ppc64le.patch b/testing/thermald/ppc64le.patch
index 52ca3adcaf..874f5bede1 100644
--- a/testing/thermald/ppc64le.patch
+++ b/testing/thermald/ppc64le.patch
@@ -1,5 +1,5 @@
diff --git a/src/thd_engine.cpp b/src/thd_engine.cpp
-index 82882dd..64e4db2 100644
+index 82882dd..51266d3 100644
--- a/src/thd_engine.cpp
+++ b/src/thd_engine.cpp
@@ -35,7 +35,9 @@
@@ -17,12 +17,12 @@ index 82882dd..64e4db2 100644
int cthd_engine::check_cpu_id() {
-#ifndef ANDROID
-+#ifndef ANDROID && !defined(__powerpc__)
++#if !defined(ANDROID) && !defined(__powerpc__)
// Copied from turbostat program
unsigned int ebx, ecx, edx, max_level;
unsigned int fms, family, model, stepping;
diff --git a/src/thd_engine_default.cpp b/src/thd_engine_default.cpp
-index 3454170..e75fdaf 100644
+index 3454170..170a148 100644
--- a/src/thd_engine_default.cpp
+++ b/src/thd_engine_default.cpp
@@ -795,14 +795,16 @@ void cthd_engine_default::workarounds()
@@ -39,7 +39,7 @@ index 3454170..e75fdaf 100644
void cthd_engine_default::workaround_rapl_mmio_power(void)
{
-#ifndef ANDROID
-+#ifndef ANDROID && !defined(__powerpc__)
++#if !defined(ANDROID) && !defined(__powerpc__)
int map_fd;
void *rapl_mem;
unsigned char *rapl_pkg_pwr_addr;