aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
Diffstat (limited to 'testing')
-rw-r--r--testing/cowpatty/APKBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/testing/cowpatty/APKBUILD b/testing/cowpatty/APKBUILD
new file mode 100644
index 0000000000..198533fe9e
--- /dev/null
+++ b/testing/cowpatty/APKBUILD
@@ -0,0 +1,31 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=cowpatty
+pkgver=4.3
+pkgrel=0
+pkgdesc="Attacking WPA/WPA2-PSK exchanges"
+url="http://www.willhackforsushi.com/Cowpatty.html"
+arch="all"
+license="GPL2+"
+depends=""
+depends_dev=""
+makedepends="libpcap-dev openssl-dev"
+install=""
+subpackages=""
+source="http://www.willhackforsushi.com/code/$pkgname/$pkgver/$pkgname-$pkgver.tgz"
+_builddir="$srcdir"/$pkgname-$pkgver
+
+build() {
+ cd "$_builddir"
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ install -m755 -D "$_builddir"/$pkgname \
+ "$pkgdir"/usr/bin/$pkgname || return 1
+ install -m755 -D "$_builddir"/genpmk \
+ "$pkgdir"/usr/bin/genpmk || return 1
+}
+
+md5sums="deccac0763a05ef7014107d347bf9190 cowpatty-4.3.tgz"