aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
Diffstat (limited to 'testing')
-rw-r--r--testing/kea/APKBUILD4
-rw-r--r--testing/kea/kea-admin-remove-builddir.patch24
2 files changed, 27 insertions, 1 deletions
diff --git a/testing/kea/APKBUILD b/testing/kea/APKBUILD
index 235555f025..3bbdd78c12 100644
--- a/testing/kea/APKBUILD
+++ b/testing/kea/APKBUILD
@@ -34,6 +34,7 @@ source="https://ftp.isc.org/isc/$pkgname/$pkgver/$pkgname-$pkgver.tar.gz
logs-location.patch
use-runstatedir-for-pid-file-location.patch
put-LOCKFILE_DIR-to-runstatedir.patch
+ kea-admin-remove-builddir.patch
kea.initd.in
"
validpgpkeys="BE0E9748B718253A28BB89FFF1B11BF05CF02E57" # Internet Systems Consortium, Inc. (Signing key, 2017-2018) <codesign@isc.org>
@@ -41,7 +42,7 @@ validpgpkeys="BE0E9748B718253A28BB89FFF1B11BF05CF02E57" # Internet Systems Conso
prepare() {
default_prepare
- # Remove the builddir path from the scripts to satisfy abuild checks.
+ # Remove the builddir path from the scripts.
# NOTE: There's a new script each release, so using patch file would be
# very inconvenient.
find src/share/database/scripts/ \
@@ -177,4 +178,5 @@ sha512sums="f84bed2e1dacd172c7aed8e4d6c11ec5e79f37ad2c7991963fc9c4a1761668f9f0e1
4336bb6708d51729065da4dd3a3e96bbcbac7716b4bbde360af3c4599719c2fa9362055ae6c00043e7581f2f4af5a51d24f2e8cfaabefdb1f4d545c24af33f94 logs-location.patch
574b4aacef03c2d4a556b4ff8b152b66efd6fdc27ad09373d41c72df15f8a2cd2386e0bbe7e07f1370d9cd11e0954fc679f3d57e6b647d601cc06e0c63bc8712 use-runstatedir-for-pid-file-location.patch
062e6eb88c49aeeac5d78c37c43cda1ff753e19f833aaa1525e37f66eede819910d4849bd954f3ef8ceb1b13e747953c99e2a9a4d9755b6da8d82c4e08b2b55c put-LOCKFILE_DIR-to-runstatedir.patch
+5b93d96f2cbdce327ffceef5ace19ba5327a0c7d0d61714e35a0d72912ecbbec6a1864249612b48f8db20dffc3622170c3e21b1a67297fd834f47b94db85b9d7 kea-admin-remove-builddir.patch
57bed5c19aeb03218228a0b1244e7036ed80eaacb55e9799c9ba86619662f34c858512212b69b30c11b9b592ff776a82193ccd6fccffb6b3daa016e6d9197528 kea.initd.in"
diff --git a/testing/kea/kea-admin-remove-builddir.patch b/testing/kea/kea-admin-remove-builddir.patch
new file mode 100644
index 0000000000..70cf7487d9
--- /dev/null
+++ b/testing/kea/kea-admin-remove-builddir.patch
@@ -0,0 +1,24 @@
+From: Kea <isc-kea@packages.debian.org>
+Date: Tue, 19 Feb 2019 12:39:35 +0000
+Subject: kea_admin_fix
+
+Removed the fallback to the build version of kea-admin since it will not exist on users hosts.
+
+Patch-Source: https://sources.debian.org/src/isc-kea/1.5.0-2/debian/patches/0003-kea_admin_fix/
+---
+ src/bin/admin/kea-admin.in | 2 --
+ 1 file changed, 2 deletions(-)
+
+diff --git a/src/bin/admin/kea-admin.in b/src/bin/admin/kea-admin.in
+index 3d391df..dcb8bff 100644
+--- a/src/bin/admin/kea-admin.in
++++ b/src/bin/admin/kea-admin.in
+@@ -37,8 +37,6 @@ dump_qry=""
+ # use build version if it isn't.
+ if [ -e @datarootdir@/@PACKAGE_NAME@/scripts/admin-utils.sh ]; then
+ . @datarootdir@/@PACKAGE_NAME@/scripts/admin-utils.sh
+-else
+- . @abs_top_srcdir@/src/bin/admin/admin-utils.sh
+ fi
+
+ # Prints out usage version.