aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
Diffstat (limited to 'testing')
-rw-r--r--testing/consul/APKBUILD4
-rw-r--r--testing/consul/consul.post-deinstall7
-rw-r--r--testing/consul/consul.pre-deinstall6
3 files changed, 2 insertions, 15 deletions
diff --git a/testing/consul/APKBUILD b/testing/consul/APKBUILD
index 2638d44861..11f54888ba 100644
--- a/testing/consul/APKBUILD
+++ b/testing/consul/APKBUILD
@@ -2,14 +2,14 @@
# Maintainer:
pkgname=consul
pkgver=0.7.0
-pkgrel=0
+pkgrel=1
pkgdesc="A tool for service discovery, monitoring and configuration"
url="https://www.consul.io/"
arch="all !aarch64"
license="MPL 2.0"
depends=""
makedepends="go"
-install="$pkgname.pre-install $pkgname.pre-deinstall $pkgname.post-deinstall"
+install="$pkgname.pre-install"
pkgusers="consul"
pkggroups="consul"
options="!strip"
diff --git a/testing/consul/consul.post-deinstall b/testing/consul/consul.post-deinstall
deleted file mode 100644
index a4da5f3354..0000000000
--- a/testing/consul/consul.post-deinstall
+++ /dev/null
@@ -1,7 +0,0 @@
-#!/bin/sh
-
-# Delete consul group and user
-delgroup consul 2> /dev/null
-deluser consul 2> /dev/null
-exit 0
-
diff --git a/testing/consul/consul.pre-deinstall b/testing/consul/consul.pre-deinstall
deleted file mode 100644
index e352a05546..0000000000
--- a/testing/consul/consul.pre-deinstall
+++ /dev/null
@@ -1,6 +0,0 @@
-#!/bin/sh
-
-# Stop consul service
-rc-service consul stop &> /dev/null
-exit 0
-