aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
Diffstat (limited to 'testing')
-rw-r--r--testing/php7-couchbase/APKBUILD9
1 files changed, 7 insertions, 2 deletions
diff --git a/testing/php7-couchbase/APKBUILD b/testing/php7-couchbase/APKBUILD
index 91423f60de..7f50793905 100644
--- a/testing/php7-couchbase/APKBUILD
+++ b/testing/php7-couchbase/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Nathan Johnson <nathan@nathanjohnson.info>
pkgname=php7-couchbase
_pkgreal=couchbase
-pkgver=2.4.4
+pkgver=2.4.5
pkgrel=0
_phpver=${pkgname#php}
_phpver=${_phpver%%-*}
@@ -24,6 +24,11 @@ build() {
make
}
+check() {
+ cd "$builddir"
+ make NO_INTERACTION=1 REPORT_EXIT_STATUS=1 test
+}
+
package() {
local confdir="$pkgdir/etc/php$_phpver/conf.d"
cd "$builddir"
@@ -34,4 +39,4 @@ package() {
echo "extension=$_pkgreal.so" > "$confdir"/$_pkgreal.ini
}
-sha512sums="42817da0ed9dcd72db83eca25bef1d9a31e53164083964e9ac8d65fa7784f41d0274bb1353b78f92bce90a602d3e2c1796af6767d010c8e2910543dba31df6b2 php7-couchbase-2.4.4.tgz"
+sha512sums="c1ee8f8dc58c1b79f8c3dd3ebb27be8436b76debde9c965758b5b8e5918b92f66a8f1afbf943f1f81ba8110e4a4bde089a4fc930a7d9240414102be9221471df php7-couchbase-2.4.5.tgz"