aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/slowhttptest/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'unmaintained/slowhttptest/APKBUILD')
-rw-r--r--unmaintained/slowhttptest/APKBUILD44
1 files changed, 44 insertions, 0 deletions
diff --git a/unmaintained/slowhttptest/APKBUILD b/unmaintained/slowhttptest/APKBUILD
new file mode 100644
index 0000000000..13033a7625
--- /dev/null
+++ b/unmaintained/slowhttptest/APKBUILD
@@ -0,0 +1,44 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=slowhttptest
+pkgver=1.6
+pkgrel=0
+pkgdesc="An application Layer DoS attack simulator"
+url="http://code.google.com/p/slowhttptest"
+arch="all"
+license="ASL 2.0"
+depends=""
+depends_dev=""
+makedepends="openssl-dev"
+install=""
+subpackages="$pkgname-doc"
+source="http://slowhttptest.googlecode.com/files/$pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+md5sums="72ba999ffee6b00abe25e597fa1d83b2 slowhttptest-1.6.tar.gz"
+sha256sums="77c54a64cfa5f12a84729833d9b98d5f27f828f51a5e42ad5914482d0b2bd0d6 slowhttptest-1.6.tar.gz"
+sha512sums="34360be27120f5922f68f25690d10d7c2e352c99cdc0224a5de5ad935d00b5e0b79ab9f80dd772fab098767acc1bdba41f7279470e75cd9dba9cf4f6aed28774 slowhttptest-1.6.tar.gz"