aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/vdr/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'unmaintained/vdr/APKBUILD')
-rw-r--r--unmaintained/vdr/APKBUILD103
1 files changed, 0 insertions, 103 deletions
diff --git a/unmaintained/vdr/APKBUILD b/unmaintained/vdr/APKBUILD
deleted file mode 100644
index 09376e2760..0000000000
--- a/unmaintained/vdr/APKBUILD
+++ /dev/null
@@ -1,103 +0,0 @@
-# Contributor: Carlo Landmeter <clandmeter@gmail.com>
-# Maintainer: Taner Tas <taner76@gmail.com>
-pkgname=vdr
-pkgver=2.3.8
-pkgrel=1
-pkgdesc="Video Disk Recorder"
-url="http://www.tvdr.de/"
-arch="all"
-license="GPL2"
-depends=""
-depends_dev="libexecinfo-dev fontconfig-dev freetype-dev gettext-dev libjpeg-turbo-dev fribidi-dev
- libcap-dev alsa-lib-dev libvdpau-dev libva-dev libx11-dev xcb-util-dev xcb-util-wm-dev
- ffmpeg-dev libcdio-dev mpv"
-makedepends="$depends_dev coreutils"
-subpackages="$pkgname-dev $pkgname-doc $pkgname-lang $pkgname-softhddevice $pkgname-femon $pkgname-mpv"
-options="!check"
-
-_femon_ver=28e4fb8de8578a1b8a36eb38d2e710dc60be7e3f
-_softhddevice_ver=9c90c5afbd85a113781a7d8fb10e7d68a109c698
-_mpv_ver=87543f7058b88a3ace8550551bb3982cc304720e
-_vnsiserver_ver=2c42df3cf1ba37184e9106091f383ea6009490da
-_streamdev_ver=b84b7d858cf4f6f3473ba72d456326c048946cb0
-
-source="ftp://ftp.tvdr.de/vdr/Developer/vdr-${pkgver}.tar.bz2
- vdr-plugin-femon-${_femon_ver}.tar.gz::https://github.com/rofafor/vdr-plugin-femon/archive/${_femon_ver}.tar.gz
- vdr-plugin-softhddevice-${_softhddevice_ver}.tar.gz::https://github.com/rofafor/vdr-plugin-softhddevice/archive/${_softhddevice_ver}.tar.gz
- vdr-plugin-mpv-${_mpv_ver}.tar.gz::https://github.com/chriszero/vdr-plugin-mpv/archive/${_mpv_ver}.tar.gz
- vdr-plugin-vnsiserver-${_vnsiserver_ver}.tar.gz::https://github.com/FernetMenta/vdr-plugin-vnsiserver/archive/${_vnsiserver_ver}.tar.gz
- vdr-plugin-streamdev-${_streamdev_ver}.tar.gz::https://projects.vdr-developer.org/git/vdr-plugin-streamdev.git/snapshot/vdr-plugin-streamdev-${_streamdev_ver}.tar.gz
- musl-compat.patch
- softhddevice-musl.patch
- streamdev-for-2.3.7.patch
- Make.config"
-
-builddir="$srcdir/$pkgname-$pkgver"
-
-prepare() {
- rm -rf ${builddir}/PLUGINS/src/skincurses
- cp -aP $srcdir/vdr-plugin-femon-${_femon_ver} ${builddir}/PLUGINS/src/femon
- cp -aP $srcdir/vdr-plugin-softhddevice-${_softhddevice_ver} ${builddir}/PLUGINS/src/softhddevice
- cp -aP $srcdir/vdr-plugin-mpv-${_mpv_ver} ${builddir}/PLUGINS/src/mpv
- cp -aP $srcdir/vdr-plugin-vnsiserver-${_vnsiserver_ver} ${builddir}/PLUGINS/src/vnsiserver
- cp -aP $srcdir/vdr-plugin-streamdev-${_streamdev_ver} ${builddir}/PLUGINS/src/streamdev
- cd "$builddir"
- default_prepare
-}
-
-build() {
- cd "$builddir"
- cp $srcdir/Make.config $builddir
- make
-}
-
-softhddevice() {
- depends="${pkgname} alsa-lib libvdpau libva ffmpeg-libs"
- cd "$pkgdir"
- mkdir -p ${subpkgdir}/usr/lib/vdr
- mv usr/lib/vdr/lib${subpkgname}.so.${pkgver} ${subpkgdir}/usr/lib/vdr
-}
-
-femon() {
- depends="${pkgname}"
- cd "$pkgdir"
- mkdir -p ${subpkgdir}/usr/lib/vdr
- mv usr/lib/vdr/lib${subpkgname}.so.${pkgver} ${subpkgdir}/usr/lib/vdr
-}
-
-mpv() {
- depends="${pkgname} mpv-libs libcdio"
- cd "$pkgdir"
- mkdir -p ${subpkgdir}/usr/lib/vdr
- mv usr/lib/vdr/lib${subpkgname}.so.${pkgver} ${subpkgdir}/usr/lib/vdr
-}
-
-vnsiserver() {
- depends="${pkgname}"
- cd "$pkgdir"
- mkdir -p ${subpkgdir}/usr/lib/vdr
- mv usr/lib/vdr/lib${subpkgname}.so.${pkgver} ${subpkgdir}/usr/lib/vdr
-}
-
-streamdev() {
- depends="${pkgname}"
- cd "$pkgdir"
- mkdir -p ${subpkgdir}/usr/lib/vdr
- mv lib${subpkgname}-server.so.${pkgver} ${subpkgdir}/usr/lib/vdr
- mv lib${subpkgname}-client.so.${pkgver} ${subpkgdir}/usr/lib/vdr
-}
-
-package() {
- cd "$builddir"
- make -j1 DESTDIR="$pkgdir" install
-}
-sha512sums="9dd8d90b365c255bfdf334f6f20a65671dbaf02da68dffdba003fe59243fc0636213b9df47bd6d350046fe4c6b3cb7568f2d9fd5ccdbff534328bc82e5a18d0b vdr-2.3.8.tar.bz2
-4f09246b0293617ee959ea768f215724c3996e10d7ee09399ce7c571d30e34da062df84d44465142261ea06069b09bac8b4a683a8dee54713385cc73f485c426 vdr-plugin-femon-28e4fb8de8578a1b8a36eb38d2e710dc60be7e3f.tar.gz
-e6f0a6c92ab4ce282ece053eb254fe8be51c2284651a6c1c215d5cf2a51093dd387490a8731b8d41ba7c0f87ea9e0f638a89e56f718f73691fb4e195a5fbf409 vdr-plugin-softhddevice-9c90c5afbd85a113781a7d8fb10e7d68a109c698.tar.gz
-a9047da75cc11e675123d418c15a9712ac019658836630c7949699e39a0ade555dd2d52845abffd2cce0857e2c810f4bb5a7bf8b80dbc1a3c1b75002392dece3 vdr-plugin-mpv-87543f7058b88a3ace8550551bb3982cc304720e.tar.gz
-8fd60ff87bdc5eeadd6438902171340df940293c275fde0bda413c7bb788a8d08942b24523998692111621117b0b47e35eb8c65c55a7365c18bf520afa019167 vdr-plugin-vnsiserver-2c42df3cf1ba37184e9106091f383ea6009490da.tar.gz
-63b0fb071f0bd38a2f8077ae5a71a484217c5c887ae815161c757058ecd75360a4f78c86eb12060b45404113581f3bcb0b2ea814aa6b60d18f88f84eba8b8f5b vdr-plugin-streamdev-b84b7d858cf4f6f3473ba72d456326c048946cb0.tar.gz
-f47461445515e44f5cdb9c6d3b1bcae323bb83ba3de7c77a3be4d9ac99ed9e76ebe2ee720660c5593fa4b6995366b9d98bf1683f7b8786518a444de7754731ca musl-compat.patch
-c6f89ba45bf02c0d85963797ff579f3ae0616a827f2b883685b44241bddea7916c3d6da21790553d161884c39d12ee21fc10f7d9d5aee9767cdde10cde02baac softhddevice-musl.patch
-60262ccb296bb098a469cce102f97da191af811ba7b0cbabc9d071275b1262f71e57933541b9a30fa0f4336384b2a5a711577e772ff7c751ddb07a9cbdd067dc streamdev-for-2.3.7.patch
-0add913727ebc2ab290211354e2310573f7ece14fcad8636b0a1d7cff49e32027e2d5a6aab3050e577f62387efff8aecc73dfc16e0f876ae28c5257fc9b6c67f Make.config"