summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2010-05-19 09:28:46 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2010-05-19 09:28:46 +0000
commit139c5b05dfde86523f53eb18e1e8eee913fe6a89 (patch)
tree2e6f376cc075b0a4e00172ecbd7239a8e1762b51
parentb95e47c98a7fa1f9099ef1cc31fb829ef584f13a (diff)
downloadaports-139c5b05dfde86523f53eb18e1e8eee913fe6a89.tar.bz2
aports-139c5b05dfde86523f53eb18e1e8eee913fe6a89.tar.xz
testing/libical: new aport
An open source reference implementation of the icalendar data type and serialization format http://sourceforge.net/projects/freeassociation/
-rw-r--r--testing/libical/APKBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/testing/libical/APKBUILD b/testing/libical/APKBUILD
new file mode 100644
index 000000000..122662217
--- /dev/null
+++ b/testing/libical/APKBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=libical
+pkgver=0.44
+pkgrel=0
+pkgdesc="An open source reference implementation of the icalendar data type and serialization format"
+url="http://sourceforge.net/projects/freeassociation/"
+license="LGPL MPL"
+depends=
+makedepends=
+subpackages="$pkgname-dev"
+source="http://downloads.sourceforge.net/freeassociation/$pkgname-$pkgver.tar.gz"
+
+build() {
+ cd "$srcdir"/$pkgname-$pkgver
+ ./configure --prefix=/usr \
+ --enable-shared \
+ --disable-static \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$srcdir"/$pkgname-$pkgver
+ make DESTDIR="$pkgdir" install
+}
+md5sums="e0403c31e1ed82569325685f8c15959c libical-0.44.tar.gz"