summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2014-04-02 08:24:12 +0300
committerTimo Teräs <timo.teras@iki.fi>2014-04-02 08:24:12 +0300
commit1930b6d8b95088b87f8855b595a9f11dce45bee5 (patch)
treeefb89e8d86a549e7db61df628dca21f2155df7a3
parent5c8cfe25633f541caff527f2f205320b97dd38db (diff)
downloadaports-1930b6d8b95088b87f8855b595a9f11dce45bee5.tar.bz2
aports-1930b6d8b95088b87f8855b595a9f11dce45bee5.tar.xz
main/xulrunner: fix pax mark on x86
-rw-r--r--main/xulrunner/APKBUILD7
1 files changed, 5 insertions, 2 deletions
diff --git a/main/xulrunner/APKBUILD b/main/xulrunner/APKBUILD
index 7d846b3c3..41ec53f1b 100644
--- a/main/xulrunner/APKBUILD
+++ b/main/xulrunner/APKBUILD
@@ -3,7 +3,7 @@
pkgname=xulrunner
pkgver=26.0
_ffoxver=$pkgver
-pkgrel=5
+pkgrel=6
pkgdesc="runtime environment for xul-based applications"
url="http://developer.mozilla.org/en/XULRunner"
arch="all"
@@ -102,7 +102,10 @@ package() {
cd "$_builddir"
# only used for startupcache creation.
- paxctl -c -m */dist/bin/xpcshell || return 1
+ local paxflags="-m"
+ [ "$CARCH" = "x86" ] && paxflags="-msp"
+
+ paxctl -c $paxflags */dist/bin/xpcshell || return 1
make -j1 DESTDIR="$pkgdir" -f client.mk install || return 1