summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2015-03-18 12:24:41 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2015-03-18 12:24:41 +0000
commit3b7da6bf3be01ad9525ecb733dc62ef4c8eb48ea (patch)
tree2e54c00ab44133fb81a80f1c72880331fa319eb9
parentb6249ee9e546c1b84b77dc15446dbec7af40a7aa (diff)
downloadaports-3b7da6bf3be01ad9525ecb733dc62ef4c8eb48ea.tar.bz2
aports-3b7da6bf3be01ad9525ecb733dc62ef4c8eb48ea.tar.xz
main/util-linux: upgrade to 2.26.1
-rw-r--r--main/util-linux/0001-hexdump-use-ll-format-modifier-instead-of-the-non-st.patch60
-rw-r--r--main/util-linux/0001-switch_root-use-typeof-instead-of-__SWORD_TYPE-for-s.patch67
-rw-r--r--main/util-linux/APKBUILD24
3 files changed, 8 insertions, 143 deletions
diff --git a/main/util-linux/0001-hexdump-use-ll-format-modifier-instead-of-the-non-st.patch b/main/util-linux/0001-hexdump-use-ll-format-modifier-instead-of-the-non-st.patch
deleted file mode 100644
index 8a0c24c12..000000000
--- a/main/util-linux/0001-hexdump-use-ll-format-modifier-instead-of-the-non-st.patch
+++ /dev/null
@@ -1,60 +0,0 @@
-From ef1ba1cd2af353f81afb57222ed26a30b116aa29 Mon Sep 17 00:00:00 2001
-From: Natanael Copa <ncopa@alpinelinux.org>
-Date: Thu, 8 May 2014 13:22:00 +0000
-Subject: [PATCH] hexdump: use 'll' format modifier instead of the non-standard
- 'q'.
-
-The printf(3) man page says about 'q':
-("quad". 4.4BSD and Linux libc5 only. Don't use.) This is a synonym for ll.
-
-This fixes hexdump with musl libc.
-
-Signed-off-by: Natanael Copa <ncopa@alpinelinux.org>
----
- text-utils/hexdump-parse.c | 16 +++++++++-------
- 1 file changed, 9 insertions(+), 7 deletions(-)
-
-diff --git a/text-utils/hexdump-parse.c b/text-utils/hexdump-parse.c
-index 8d14c5b..9eb016d 100644
---- a/text-utils/hexdump-parse.c
-+++ b/text-utils/hexdump-parse.c
-@@ -226,7 +226,7 @@ void rewrite_rules(struct hexdump_fs *fs, struct hexdump *hex)
- struct hexdump_fu *fu;
- struct list_head *p, *q;
- char *p1, *p2, *fmtp;
-- char savech, cs[3];
-+ char savech, cs[4];
- int nconv, prec = 0;
-
- list_for_each (p, &fs->fulist) {
-@@ -301,9 +301,10 @@ void rewrite_rules(struct hexdump_fs *fs, struct hexdump *hex)
- goto isint;
- } else if (first_letter(cs, "ouxX")) {
- pr->flags = F_UINT;
--isint: cs[2] = '\0';
-- cs[1] = cs[0];
-- cs[0] = 'q';
-+isint: cs[3] = '\0';
-+ cs[2] = cs[0];
-+ cs[1] = 'l';
-+ cs[0] = 'l';
- switch(fu->bcnt) {
- case 0:
- pr->bcnt = 4;
-@@ -355,9 +356,10 @@ isint: cs[2] = '\0';
- pr->flags = F_ADDRESS;
- ++p2;
- if (first_letter(p1 + 2, "dox")) {
-- cs[0] = 'q';
-- cs[1] = p1[2];
-- cs[2] = '\0';
-+ cs[0] = 'l';
-+ cs[1] = 'l';
-+ cs[2] = p1[2];
-+ cs[3] = '\0';
- } else {
- p1[3] = '\0';
- badconv(p1);
---
-2.1.2
-
diff --git a/main/util-linux/0001-switch_root-use-typeof-instead-of-__SWORD_TYPE-for-s.patch b/main/util-linux/0001-switch_root-use-typeof-instead-of-__SWORD_TYPE-for-s.patch
deleted file mode 100644
index db76b7a5b..000000000
--- a/main/util-linux/0001-switch_root-use-typeof-instead-of-__SWORD_TYPE-for-s.patch
+++ /dev/null
@@ -1,67 +0,0 @@
-From d8aa7c8b2b1a5233ce8f3dde19490899bb50e4a2 Mon Sep 17 00:00:00 2001
-From: Natanael Copa <ncopa@alpinelinux.org>
-Date: Wed, 29 Oct 2014 08:42:09 +0000
-Subject: [PATCH] switch_root: use typeof() instead of __SWORD_TYPE for statfs
- compare
-
-Identifiers prefixed with __ are normally for internal use and should
-normally not be used outside libc.
-
-This fixes the following compile error with musl libc:
-sys-utils/switch_root.c:184:25: error: '__SWORD_TYPE' undeclared (first use in this function)
- (stfs.f_type == (__SWORD_TYPE)STATFS_RAMFS_MAGIC ||
- ^
-
-Also, statfs(2) man page is also wrong on some systems, because f_type
-is not __SWORD_TYPE on some architecures.
-
-The following program:
-
-int main(int argc, char**argv)
-{
- struct statfs s;
- statfs(argv[1], &s);
-
- printf("sizeof(f_type) = %d\n", sizeof(s.f_type));
- printf("sizeof(__SWORD_TYPE) = %d\n", sizeof(__SWORD_TYPE));
- printf("sizeof(long) = %d\n", sizeof(long));
- printf("sizeof(int) = %d\n", sizeof(int));
- if (sizeof(s.f_type) == sizeof(int)) {
- printf("f_type = 0x%x\n", s.f_type);
- } else {
- printf("f_type = 0x%lx\n", s.f_type);
- }
- return 0;
-}
-
-executed on s390x gives for a btrfs:
-
-sizeof(f_type) = 4
-sizeof(__SWORD_TYPE) = 8
-sizeof(long) = 8
-sizeof(int) = 4
-f_type = 0x9123683e
-
-Signed-off-by: Natanael Copa <ncopa@alpinelinux.org>
----
- sys-utils/switch_root.c | 4 ++--
- 1 file changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/sys-utils/switch_root.c b/sys-utils/switch_root.c
-index 6822a5d..3fbecdd 100644
---- a/sys-utils/switch_root.c
-+++ b/sys-utils/switch_root.c
-@@ -181,8 +181,8 @@ static int switchroot(const char *newroot)
- if (pid <= 0) {
- struct statfs stfs;
- if (fstatfs(cfd, &stfs) == 0 &&
-- (stfs.f_type == (__SWORD_TYPE)STATFS_RAMFS_MAGIC ||
-- stfs.f_type == (__SWORD_TYPE)STATFS_TMPFS_MAGIC))
-+ (stfs.f_type == (typeof(stfs.f_type))STATFS_RAMFS_MAGIC ||
-+ stfs.f_type == (typeof(stfs.f_type))STATFS_TMPFS_MAGIC))
- recursiveRemove(cfd);
- else
- warn(_("old root filesystem is not an initramfs"));
---
-2.1.2
-
diff --git a/main/util-linux/APKBUILD b/main/util-linux/APKBUILD
index de5c88719..d7f0f1536 100644
--- a/main/util-linux/APKBUILD
+++ b/main/util-linux/APKBUILD
@@ -1,14 +1,14 @@
# Contributor: Leonardo Arena <rnalrd@alpinelinux.org>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=util-linux
-pkgver=2.25.2
+pkgver=2.26.1
case $pkgver in
*.*.*) _v=${pkgver%.*};;
*.*) _v=$pkgver;;
esac
-pkgrel=2
+pkgrel=0
pkgdesc="Random collection of Linux utilities"
url="http://kernel.org/~kzak/util-linux/"
arch="all"
@@ -21,8 +21,6 @@ options="suid"
source="http://www.kernel.org/pub/linux/utils/util-linux/v${_v}/util-linux-$pkgver.tar.xz
fix-setenv-usage.patch
ttydefaults.h
- 0001-hexdump-use-ll-format-modifier-instead-of-the-non-st.patch
- 0001-switch_root-use-typeof-instead-of-__SWORD_TYPE-for-s.patch
"
subpackages="$pkgname-doc $pkgname-dev libuuid libblkid libmount sfdisk cfdisk
mcookie blkid py-libmount:_py"
@@ -135,18 +133,12 @@ _py() {
mv "$pkgdir"/usr/lib/python* "$subpkgdir"/usr/lib/
}
-md5sums="cab3d7be354000f629bc601238b629b3 util-linux-2.25.2.tar.xz
+md5sums="2308850946766677f3fabe0685e85de8 util-linux-2.26.1.tar.xz
7033d8ec10f6ff52c8120afbe9522490 fix-setenv-usage.patch
-6196f1ce853dfaf717569c1e35555d6d ttydefaults.h
-0543fc61b54f8c5235d123d53c1f450b 0001-hexdump-use-ll-format-modifier-instead-of-the-non-st.patch
-d9004b0a3ebd37054ec872d71bff0bbb 0001-switch_root-use-typeof-instead-of-__SWORD_TYPE-for-s.patch"
-sha256sums="e0457f715b73f4a349e1acb08cb410bf0edc9a74a3f75c357070f31f70e33cd6 util-linux-2.25.2.tar.xz
+6196f1ce853dfaf717569c1e35555d6d ttydefaults.h"
+sha256sums="22dc1c957262e2cbdfb4d524a63d5cd4f219d3ac9b5eab570fc771076799bb6e util-linux-2.26.1.tar.xz
ff1625c8d479511b263c1beb86bf6c30c2e13142183647f4fa8c62ff1bc68910 fix-setenv-usage.patch
-46faf1198bd884d12c5d45019a5fec8dfdefeae6721d8c9f3da89921acdb2a6d ttydefaults.h
-751a9657d7b59325cb807f2190afa1109de121152aaad0f079139d582cb4d637 0001-hexdump-use-ll-format-modifier-instead-of-the-non-st.patch
-d63752f24ad4b98d7a98b653d8ffd2b8146be0bf598c61e979fcc3c2ec613116 0001-switch_root-use-typeof-instead-of-__SWORD_TYPE-for-s.patch"
-sha512sums="cf8c5bde78f844425150c2a81bdecb87aa57bcd5cebd177a78160835627f58037fa2cfe4db26fd8f35eedb3beb499a91492a297a27d065465e2ea0c6218dc387 util-linux-2.25.2.tar.xz
+46faf1198bd884d12c5d45019a5fec8dfdefeae6721d8c9f3da89921acdb2a6d ttydefaults.h"
+sha512sums="9321793b3fa219ffc46e10639b9e45094c3cae6c48be4b80e652d9768f40dcedbd49342e17345b61c85f46540a7bd93d118a8e226c315e112bb2e959e2855ad9 util-linux-2.26.1.tar.xz
310acfe2f171010014d25b1788ea64bffc5a315f4fef8d3b8fc9b003bda8810111b12987052eb2d5856500bd6b742792c977608fe9459ce2efe7545ef0054588 fix-setenv-usage.patch
-876bb9041eca1b2cca1e9aac898f282db576f7860aba690a95c0ac629d7c5b2cdeccba504dda87ff55c2a10b67165985ce16ca41a0694a267507e1e0cafd46d9 ttydefaults.h
-4124453ae30efd5d886de9b51ae1854715e77525e0bbff427eec2cb3569dbd9c702b76dd8af532f83f8ba6990056993873c4489b7438391f649ab63f29f32ef0 0001-hexdump-use-ll-format-modifier-instead-of-the-non-st.patch
-9cde5650e2dad4161f86101179297b9177f588368e453c83b874694ce18e9eb23973053171db61ff7abf550008e5021febbfdb8a47091a23520ade84d5eef59a 0001-switch_root-use-typeof-instead-of-__SWORD_TYPE-for-s.patch"
+876bb9041eca1b2cca1e9aac898f282db576f7860aba690a95c0ac629d7c5b2cdeccba504dda87ff55c2a10b67165985ce16ca41a0694a267507e1e0cafd46d9 ttydefaults.h"