summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDuane Hughes <duanejevon@gmail.com>2011-01-28 09:30:24 +0000
committerTimo Teräs <timo.teras@iki.fi>2011-02-03 13:15:32 +0200
commit4514927cd69fa42fab58c04a9dd3ff811ffbf1d7 (patch)
treef78a1c98d94621d1104cd9c7619b51b3e972ac30
parent161748dbe02c709b2e833b8dce9eb8200aae3f8b (diff)
downloadaports-4514927cd69fa42fab58c04a9dd3ff811ffbf1d7.tar.bz2
aports-4514927cd69fa42fab58c04a9dd3ff811ffbf1d7.tar.xz
testing/lockfile-progs: new aport
utilities for safely unlocking locked files/mailboxes
-rw-r--r--testing/lockfile-progs/APKBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/testing/lockfile-progs/APKBUILD b/testing/lockfile-progs/APKBUILD
new file mode 100644
index 000000000..a1c5aad9f
--- /dev/null
+++ b/testing/lockfile-progs/APKBUILD
@@ -0,0 +1,32 @@
+# Contributor: Duane Hughes <duanejevon@gmail.com
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=lockfile-progs
+pkgver=0.1.15
+pkgrel=0
+pkgdesc="Programs for locking and unlocking files and mailboxes"
+url="http://packages.debian.org/sid/lockfile-progs"
+arch="all"
+license="GPL"
+depends="liblockfile"
+makedepends="liblockfile-dev"
+install=
+subpackages="$pkgname-doc"
+source="http://ftp.debian.org/debian/pool/main/l/lockfile-progs/${pkgname}_$pkgver.tar.gz"
+
+_builddir="$srcdir"/sid
+
+build() {
+ cd "$_builddir"
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+
+ install -d "$pkgdir"/usr/bin
+ install -d "$pkgdir"/usr/share/man
+ install -m 755 "$_builddir"/bin/* "$pkgdir"/usr/bin
+ install -m 644 "$_builddir"/man/* "$pkgdir"/usr/share/man
+}
+
+md5sums="abfcda83a1868073673f4d78066b8f8a lockfile-progs_0.1.15.tar.gz"