summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2011-08-04 06:45:48 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2011-08-04 07:56:02 +0000
commit510621e468a5c3e5118a1a2907a9fbed41373116 (patch)
treeaf9e188455920ad72306c150eb9fa021dbe3d4aa
parentb0490348af4dfdee71ae80470edf9e3223e873df (diff)
downloadaports-510621e468a5c3e5118a1a2907a9fbed41373116.tar.bz2
aports-510621e468a5c3e5118a1a2907a9fbed41373116.tar.xz
main/webkit: upgrade to 1.4.2
-rw-r--r--main/webkit/APKBUILD10
-rw-r--r--main/webkit/libpng-1.5.patch48
2 files changed, 4 insertions, 54 deletions
diff --git a/main/webkit/APKBUILD b/main/webkit/APKBUILD
index 5d8a4f775..34ac11ada 100644
--- a/main/webkit/APKBUILD
+++ b/main/webkit/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=webkit
-pkgver=1.4.1
-pkgrel=2
+pkgver=1.4.2
+pkgrel=0
pkgdesc="portable web rendering engine WebKit for GTK+"
url="http://webkitgtk.org/"
arch="all"
@@ -18,8 +18,7 @@ makedepends="
"
install=
subpackages="$pkgname-dev gtklauncher"
-source="http://webkitgtk.org/$pkgname-$pkgver.tar.gz
- libpng-1.5.patch"
+source="http://webkitgtk.org/$pkgname-$pkgver.tar.gz"
depends_dev="gtk+-dev libsoup-dev gstreamer-dev"
_builddir="$srcdir"/$pkgname-$pkgver
@@ -60,5 +59,4 @@ gtklauncher() {
"$subpkgdir"/usr/bin/GtkLauncher
}
-md5sums="c1a4f732a77d6f8197437b50678d3dbc webkit-1.4.1.tar.gz
-e86d4770a37448eb508520b3ae766695 libpng-1.5.patch"
+md5sums="361f8420e93d12101d650758fec09fa0 webkit-1.4.2.tar.gz"
diff --git a/main/webkit/libpng-1.5.patch b/main/webkit/libpng-1.5.patch
deleted file mode 100644
index ecf533d6f..000000000
--- a/main/webkit/libpng-1.5.patch
+++ /dev/null
@@ -1,48 +0,0 @@
---- webkit-1.4.0.orig/Source/WebCore/platform/image-decoders/png/PNGImageDecoder.cpp
-+++ webkit-1.4.0/Source/WebCore/platform/image-decoders/png/PNGImageDecoder.cpp
-@@ -226,7 +226,7 @@
- #ifdef PNG_iCCP_SUPPORTED
- char* profileName;
- int compressionType;
-- char* profile;
-+ png_byte* profile;
- png_uint_32 profileLength;
- if (png_get_iCCP(png, info, &profileName, &compressionType, &profile, &profileLength)) {
- ColorProfile colorProfile;
-@@ -241,11 +241,11 @@
- {
- png_structp png = m_reader->pngPtr();
- png_infop info = m_reader->infoPtr();
-- png_uint_32 width = png->width;
-- png_uint_32 height = png->height;
-+ png_uint_32 width = png_get_image_width(png, info);
-+ png_uint_32 height = png_get_image_height(png, info);
-
- // Protect against large images.
-- if (png->width > cMaxPNGSize || png->height > cMaxPNGSize) {
-+ if (width > cMaxPNGSize || height > cMaxPNGSize) {
- longjmp(JMPBUF(png), 1);
- return;
- }
-@@ -318,9 +318,9 @@
- m_reader->setHasAlpha(channels == 4);
-
- if (m_reader->decodingSizeOnly()) {
-- // If we only needed the size, halt the reader.
-- m_reader->setReadOffset(m_reader->currentBufferSize() - png->buffer_size);
-- png->buffer_size = 0;
-+ // If we only needed the size, halt the reader.
-+ // '0' argument to png_process_data_pause means: Do not cache unprocessed data.
-+ m_reader->setReadOffset(m_reader->currentBufferSize() - png_process_data_pause(png, 0));
- }
- }
-
-@@ -343,7 +343,7 @@
- // For PNGs, the frame always fills the entire image.
- buffer.setOriginalFrameRect(IntRect(IntPoint(), size()));
-
-- if (m_reader->pngPtr()->interlaced)
-+ if (png_get_interlace_type(m_reader->pngPtr(), m_reader->infoPtr()) != PNG_INTERLACE_NONE)
- m_reader->createInterlaceBuffer((m_reader->hasAlpha() ? 4 : 3) * size().width() * size().height());
- }
-