summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2014-10-27 22:36:15 +0100
committerCarlo Landmeter <clandmeter@gmail.com>2014-10-27 22:36:15 +0100
commit578b727c8796a9a8669a219b042284b3d29cab6f (patch)
tree6a2a171b3e0357831ed55780ca84df7e26e45327
parent05f5f82bb70897a790109abb52ca0407ec4ab1fb (diff)
downloadaports-578b727c8796a9a8669a219b042284b3d29cab6f.tar.bz2
aports-578b727c8796a9a8669a219b042284b3d29cab6f.tar.xz
testing/telegram-cli: upgrade to 1.0.5.1
-rw-r--r--testing/telegram-cli/0001-change-public-key-location.patch25
-rw-r--r--testing/telegram-cli/0001-uclibc-does-not-provide-aio.h.patch41
-rw-r--r--testing/telegram-cli/APKBUILD36
-rw-r--r--testing/telegram-cli/musl-no-execinfo.patch31
4 files changed, 47 insertions, 86 deletions
diff --git a/testing/telegram-cli/0001-change-public-key-location.patch b/testing/telegram-cli/0001-change-public-key-location.patch
deleted file mode 100644
index 5569879e6..000000000
--- a/testing/telegram-cli/0001-change-public-key-location.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-From 193dbf82809b5ed5db8f8c37c315592d529ee37a Mon Sep 17 00:00:00 2001
-From: Carlo Landmeter <clandmeter@gmail.com>
-Date: Mon, 27 Jan 2014 13:26:44 +0000
-Subject: [PATCH] change public key location
-
----
- mtproto-client.c | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/mtproto-client.c b/mtproto-client.c
-index 06ddfdc..4279512 100644
---- a/mtproto-client.c
-+++ b/mtproto-client.c
-@@ -129,7 +129,7 @@ int Response_len;
- *
- */
-
--char *rsa_public_key_name = "tg.pub";
-+char *rsa_public_key_name = "/usr/share/telegram/tg.pub";
- RSA *pubKey;
- long long pk_fingerprint;
-
---
-1.8.5.3
-
diff --git a/testing/telegram-cli/0001-uclibc-does-not-provide-aio.h.patch b/testing/telegram-cli/0001-uclibc-does-not-provide-aio.h.patch
deleted file mode 100644
index c3abba9e2..000000000
--- a/testing/telegram-cli/0001-uclibc-does-not-provide-aio.h.patch
+++ /dev/null
@@ -1,41 +0,0 @@
-From 33d358d83dd882d1e4eebd34dc4e6cf622f0c854 Mon Sep 17 00:00:00 2001
-From: Carlo Landmeter <clandmeter@gmail.com>
-Date: Mon, 27 Jan 2014 11:42:33 +0000
-Subject: [PATCH] uclibc does not provide aio.h
-
----
- mtproto-client.c | 2 ++
- mtproto-common.c | 2 ++
- 2 files changed, 4 insertions(+)
-
-diff --git a/mtproto-client.c b/mtproto-client.c
-index 5f1a997..06ddfdc 100644
---- a/mtproto-client.c
-+++ b/mtproto-client.c
-@@ -35,7 +35,9 @@
- #include <sys/endian.h>
- #endif
- #include <sys/types.h>
-+#ifndef __UCLIBC__
- #include <aio.h>
-+#endif
- #include <netdb.h>
- #include <openssl/rand.h>
- #include <openssl/rsa.h>
-diff --git a/mtproto-common.c b/mtproto-common.c
-index ceeb5c5..1c34550 100644
---- a/mtproto-common.c
-+++ b/mtproto-common.c
-@@ -31,7 +31,9 @@
- #include <unistd.h>
- #include <fcntl.h>
- #include <sys/types.h>
-+#ifndef __UCLIBC__
- #include <aio.h>
-+#endif
- #include <netdb.h>
- #include <openssl/bn.h>
- #include <openssl/rand.h>
---
-1.8.5.3
-
diff --git a/testing/telegram-cli/APKBUILD b/testing/telegram-cli/APKBUILD
index 36753e5cc..0f7175dca 100644
--- a/testing/telegram-cli/APKBUILD
+++ b/testing/telegram-cli/APKBUILD
@@ -1,23 +1,22 @@
# Contributor: Carlo Landmeter <clandmeter@alpinelinux.org>
pkgname=telegram-cli
-pkgver=0.1_git20140127
-verbase=0.1
+pkgver=1.0.5.1
pkgrel=0
pkgdesc="Command line telegram client"
url="https://github.com/vysheng/tg"
arch="all"
license="GPL3"
depends=""
-depends_dev="readline-dev openssl-dev libconfig-dev"
+depends_dev="readline-dev openssl-dev libconfig-dev libevent-dev"
makedepends="$depends_dev"
subpackages=""
source="http://dev.alpinelinux.org/archive/$pkgname/$pkgname-$pkgver.tar.gz
0001-uclibc-does-not-provide-aio.h.patch
0001-change-public-key-location.patch"
-giturl="git://github.com/vysheng/tg.git"
-disturl="dev.alpinelinux.org:/archive/$pkgname/"
+source="$pkgname-$pkgver.tar.gz::https://github.com/vysheng/tg/archive/1.0.5.1.tar.gz
+ musl-no-execinfo.patch"
-_builddir="$srcdir/$pkgname-$pkgver"
+_builddir="$srcdir/tg-$pkgver"
prepare() {
local i
@@ -31,7 +30,7 @@ prepare() {
build() {
cd "$_builddir"
- export LUA_INCLUDE="-I/usr/include/lua5.2"
+ export LUA_INCLUDE="-I/usr/include/lua5.2"
export LUA_LIBS="-Llua5.2"
./configure --prefix=/usr \
--sysconfdir=/etc \
@@ -46,18 +45,15 @@ build() {
package() {
cd "$_builddir"
- install -D telegram \
- "$pkgdir"/usr/bin/telegram || return 1
- install -D tg.pub \
- "$pkgdir"/usr/share/telegram/tg.pub || return 1
+ install -D bin/telegram-cli \
+ "$pkgdir"/usr/bin/telegram-cli || return 1
+ install -D tg-server.pub \
+ "$pkgdir"/etc/telegram-cli/tg.pub || return 1
}
-md5sums="fc460c51f541532fa6d0a103aa41dd29 telegram-cli-0.1_git20140127.tar.gz
-ed21dd0f9056fe3a8132894ccf943844 0001-uclibc-does-not-provide-aio.h.patch
-f5bd613201b14ac0d212a82ee4ef6dbb 0001-change-public-key-location.patch"
-sha256sums="d47f47d438443b36397ecd83a6334ada2922741558b91c0075ee9358083c8b7a telegram-cli-0.1_git20140127.tar.gz
-5a92614b40c50fcd5b5601c33d87edba421086eb777663bc6c43d18734b4cfea 0001-uclibc-does-not-provide-aio.h.patch
-276ea7237e12f40f5e65d083cf8b64876aa8153adf7cbaf594a37daea71c304c 0001-change-public-key-location.patch"
-sha512sums="5a0ae0c6f8f18d7b4d1b3191044e16793a5816ebb9d1a8fc423bdbf2e0e7867819021c82dab5775c1ec2e1a86dfdb729f603a22f012ce7b8e9e51976ec11f8fb telegram-cli-0.1_git20140127.tar.gz
-46725ec1d6255ddb359e8e33a73510461264451689f7bcc14233e3730a6cae26073b0629af18443c1ad6e7140748e75293349b97ac8d8cec21b0c10541a62333 0001-uclibc-does-not-provide-aio.h.patch
-58643338812189681ca96882325050187e6a6309937fcc0af17a630d1affcbfe0d14205fd0e80dc65a51016b6ebb916fec31d275857efed8a6a2a54268d45b31 0001-change-public-key-location.patch"
+md5sums="0a9ba9b2461c9898a88a4c0957be39c3 telegram-cli-1.0.5.1.tar.gz
+55c83ab374b22146b95ad0e22a25ecc1 musl-no-execinfo.patch"
+sha256sums="5a78fd46e978ff450eda6f4664499042dddf053f4fe233fe3157499869646fb8 telegram-cli-1.0.5.1.tar.gz
+3ca117bc4ee7ce3e7ef161b56b0d833756ed4c60583f3fe420e50d7e8c5a0de4 musl-no-execinfo.patch"
+sha512sums="2d3f9e246b3caf60348cd2d02c16e2f45ac127f2d28d58f77ae890214354bc9ed16229a43d6d335fdbce2ce4ac339da9fb3beecda5143c13d5a5cfae66578621 telegram-cli-1.0.5.1.tar.gz
+50bf535dc420e53b20d385625247ea9d5df58c93b3d25cbd7757486df428f59831e71a9a377c71745c9332c5e30c49a85012520a9fabe3c06786aa41400c24ad musl-no-execinfo.patch"
diff --git a/testing/telegram-cli/musl-no-execinfo.patch b/testing/telegram-cli/musl-no-execinfo.patch
new file mode 100644
index 000000000..bf63892a2
--- /dev/null
+++ b/testing/telegram-cli/musl-no-execinfo.patch
@@ -0,0 +1,31 @@
+--- a/generate.c.orig
++++ b/generate.c
+@@ -25,7 +25,6 @@
+
+ #include <stdio.h>
+ #include <signal.h>
+-#include <execinfo.h>
+ #include <unistd.h>
+ #include <stdlib.h>
+ #include <sys/types.h>
+--- a/tlc.c.orig
++++ b/tlc.c
+@@ -35,7 +35,6 @@
+
+ #include <signal.h>
+ #include "config.h"
+-#include <execinfo.h>
+ #include <stdarg.h>
+
+ int verbosity;
+--- a/net.c.orig
++++ b/net.c
+@@ -29,7 +29,7 @@
+ #include <netdb.h>
+ #include <netinet/in.h>
+ #include <netinet/tcp.h>
+-#include <sys/fcntl.h>
++#include <fcntl.h>
+ #include <sys/types.h>
+ #include <sys/socket.h>
+ #include <errno.h>