summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2010-08-26 20:02:16 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2010-08-26 20:02:16 +0000
commit6470a1a9cdc1d9afc3abc5eddb7f28839cc9ea3e (patch)
treeaf94ceaeae30957ad1145580e28739f5e435eeae
parentff5ddc26158de35d99d38d65b512c0ef121ebe27 (diff)
downloadaports-6470a1a9cdc1d9afc3abc5eddb7f28839cc9ea3e.tar.bz2
aports-6470a1a9cdc1d9afc3abc5eddb7f28839cc9ea3e.tar.xz
main/linux-vserver: upgrade to 2.6.32.20-vs2.3.0.36.29.6
and fix building with make-3.82
-rw-r--r--main/linux-vserver/APKBUILD12
-rw-r--r--main/linux-vserver/fixes-for-using-make-3.82.patch25
2 files changed, 32 insertions, 5 deletions
diff --git a/main/linux-vserver/APKBUILD b/main/linux-vserver/APKBUILD
index ff2597f75..ebe55a639 100644
--- a/main/linux-vserver/APKBUILD
+++ b/main/linux-vserver/APKBUILD
@@ -2,10 +2,10 @@
_flavor=vserver
pkgname=linux-${_flavor}
-pkgver=2.6.32.16
+pkgver=2.6.32.20
_kernver=2.6.32
-pkgrel=2
+pkgrel=0
pkgdesc="Linux kernel with vserver"
url="http://linux-vserver.org/"
depends="mkinitfs linux-firmware"
@@ -15,8 +15,9 @@ _config=${config:-kernelconfig.${CARCH:-x86}}
install=
source="ftp://ftp.kernel.org/pub/linux/kernel/v2.6/linux-$_kernver.tar.bz2
ftp://ftp.kernel.org/pub/linux/kernel/v2.6/patch-$pkgver.bz2
- http://vserver.13thfloor.at/Experimental/patch-2.6.32.16-vs2.3.0.36.29.4.diff
+ http://vserver.13thfloor.at/Experimental/patch-2.6.32.20-vs2.3.0.36.29.6.diff
x86-setup-When-restoring-the-screen-update-boot_params-screen_info.patch
+ fixes-for-using-make-3.82.patch
kernelconfig.x86
"
subpackages="$pkgname-dev"
@@ -124,7 +125,8 @@ dev() {
}
md5sums="260551284ac224c3a43c4adac7df4879 linux-2.6.32.tar.bz2
-744890f9651962ceae7663d44b19df65 patch-2.6.32.16.bz2
-24354a6fd8798792b9ee21f086721cd9 patch-2.6.32.16-vs2.3.0.36.29.4.diff
+37cd37164dd7f288dc84f831fc33a598 patch-2.6.32.20.bz2
+e5253891d0c4eff99470c6ef9de4c075 patch-2.6.32.20-vs2.3.0.36.29.6.diff
a1bcf76870b63a4a4035a8948fb758e2 x86-setup-When-restoring-the-screen-update-boot_params-screen_info.patch
+3177c2a571b4827c1140d227e6ed06d0 fixes-for-using-make-3.82.patch
884ba32b4edb6c51426e826c44063e98 kernelconfig.x86"
diff --git a/main/linux-vserver/fixes-for-using-make-3.82.patch b/main/linux-vserver/fixes-for-using-make-3.82.patch
new file mode 100644
index 000000000..dd6e6ace9
--- /dev/null
+++ b/main/linux-vserver/fixes-for-using-make-3.82.patch
@@ -0,0 +1,25 @@
+--- linux-2.6.36-rc1/firmware/Makefile
++++ 2.6.36-rc1-make-3.82-fixes/firmware/Makefile
+@@ -142,7 +142,7 @@ fw-shipped-$(CONFIG_YAM) += yam/1200.bin
+ fw-shipped-all := $(fw-shipped-y) $(fw-shipped-m) $(fw-shipped-)
+
+ # Directories which we _might_ need to create, so we have a rule for them.
+-firmware-dirs := $(sort $(patsubst %,$(objtree)/$(obj)/%/,$(dir $(fw-external-y) $(fw-shipped-all))))
++firmware-dirs := $(sort $(addprefix $(objtree)/$(obj)/,$(dir $(fw-external-y) $(fw-shipped-all))))
+
+ quiet_cmd_mkdir = MKDIR $(patsubst $(objtree)/%,%,$@)
+ cmd_mkdir = mkdir -p $@
+--- linux-2.6.36-rc1/scripts/mkmakefile
++++ 2.6.36-rc1-make-3.82-fixes/scripts/mkmakefile
+@@ -44,7 +44,9 @@ all:
+
+ Makefile:;
+
+-\$(all) %/: all
++\$(all): all
+ @:
+
++%/: all
++ @:
+ EOF
+