summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2015-04-24 08:37:53 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2015-04-24 08:39:03 +0000
commit73e52ef77532ebfce54826d4b51a23910bea447d (patch)
tree4b358d3d7f76c0a087bd082e07fbda355353c953
parent7aefd99110015c105096eb1c6c039673b4c757b3 (diff)
downloadaports-73e52ef77532ebfce54826d4b51a23910bea447d.tar.bz2
aports-73e52ef77532ebfce54826d4b51a23910bea447d.tar.xz
main/lxc: fix /dev/shm in alpine template
-rw-r--r--main/lxc/0001-lxc-alpine-create-dev-shm-before-mounting.patch28
-rw-r--r--main/lxc/APKBUILD6
2 files changed, 33 insertions, 1 deletions
diff --git a/main/lxc/0001-lxc-alpine-create-dev-shm-before-mounting.patch b/main/lxc/0001-lxc-alpine-create-dev-shm-before-mounting.patch
new file mode 100644
index 000000000..8fe47f28c
--- /dev/null
+++ b/main/lxc/0001-lxc-alpine-create-dev-shm-before-mounting.patch
@@ -0,0 +1,28 @@
+From 41d325450e2dbd1c5c0f3fdf6171d9a746bd8f5a Mon Sep 17 00:00:00 2001
+From: Natanael Copa <ncopa@alpinelinux.org>
+Date: Fri, 24 Apr 2015 10:09:29 +0200
+Subject: [PATCH] lxc-alpine: create /dev/shm before mounting
+
+This is needed for lxc.autodev=1 to work.
+
+Signed-off-by: Natanael Copa <ncopa@alpinelinux.org>
+---
+ templates/lxc-alpine.in | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/templates/lxc-alpine.in b/templates/lxc-alpine.in
+index 886a838..963c42a 100644
+--- a/templates/lxc-alpine.in
++++ b/templates/lxc-alpine.in
+@@ -251,7 +251,7 @@ lxc.cgroup.devices.allow = c 254:0 rm
+ # mounts point
+ lxc.mount.auto=cgroup:mixed proc:mixed sys:mixed
+ lxc.mount.entry=run run tmpfs nodev,noexec,nosuid,relatime,size=1m,mode=0755 0 0
+-lxc.mount.entry=shm dev/shm tmpfs nodev,nosuid,noexec,mode=1777 0 0
++lxc.mount.entry=shm dev/shm tmpfs nodev,nosuid,noexec,mode=1777,create=dir 0 0
+
+ EOF
+
+--
+2.3.5
+
diff --git a/main/lxc/APKBUILD b/main/lxc/APKBUILD
index 67dee26ae..d8743efd7 100644
--- a/main/lxc/APKBUILD
+++ b/main/lxc/APKBUILD
@@ -4,7 +4,7 @@
pkgname=lxc
pkgver=1.1.2
_mypkgver=${pkgver/_rc/.rc}
-pkgrel=0
+pkgrel=1
pkgdesc="linux containers - tools"
url="http://lxc.sourceforge.net/"
arch="all"
@@ -18,6 +18,7 @@ options="suid"
subpackages="$pkgname-dev $pkgname-doc $pkgname-lvm lua5.2-lxc:_lua52
$pkgname-templates $pkgname-libs"
source="https://github.com/lxc/lxc/archive/lxc-$_mypkgver.tar.gz
+ 0001-lxc-alpine-create-dev-shm-before-mounting.patch
version.patch
lxc.initd
"
@@ -88,11 +89,14 @@ dev() {
}
md5sums="3297d67160f879ace9a99705ecc1ffb5 lxc-1.1.2.tar.gz
+497578ad8dc28e73a596f94f91b9ca87 0001-lxc-alpine-create-dev-shm-before-mounting.patch
79e90616b5049a472ccdcb5b1dcdd8b1 version.patch
2c21cb054c7f373318e373cfa9e4f78c lxc.initd"
sha256sums="f22fcf2659ca98dfe864e632374de98c42cdf465d0c694834b6f6098a3cb8519 lxc-1.1.2.tar.gz
+bedc3915dd960b3f659f95e4a20ed38bd1fbeec409c31d226ce3da4d10780561 0001-lxc-alpine-create-dev-shm-before-mounting.patch
b6d85fb23940d2511b3951de56b2532843c0e03ec1613548366361cc0c1a46b9 version.patch
97606cf912818f7ba099d72cb42b25fee44789c1bfd67f1c0150253e86dc6979 lxc.initd"
sha512sums="7c4c9b5418321eedcd37a3f5c2c99ff227de48f672cabd1722a74722077d33badb038675ec95fc3e338eaf2b06972c4ffb2e11f36347587ef71a95fad5b66daa lxc-1.1.2.tar.gz
+fb0738a1c5a4935d34a38960c8ff974ab98b39c869d2db95c846a6e07afdb8a315eb399134fe6aa2dbe0c70d2007b3e7ef17aa67dd3682b14f9157da47bceede 0001-lxc-alpine-create-dev-shm-before-mounting.patch
e2ffcbf55447291a8434a4f37255c3a6a119bc4116c75d205006aa2b070bf6be28535cf6107bead14bbf64bf9fa415346ab544bd1c15e1add7d1c6380e6b2def version.patch
bcf73032f2c7d17d457bcd5405071a869dcdeef36ef6b9bf5e13f21d5b4c5e1548a09114dd032863ba91358b74b2a72598bf01e53520185492593c2f4db15ffc lxc.initd"