summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorz3bra <willy@mailoo.org>2014-10-22 17:35:03 +0200
committerz3bra <willy@mailoo.org>2014-10-22 17:35:03 +0200
commit7bdf6c04532bf8da169439a6122c25dce8b6ca14 (patch)
tree52fd6175b351f4f0f606c365555c47bc72010804
parented9dccdc2f3917ea45d352806a0701ef05ba5a3b (diff)
downloadaports-7bdf6c04532bf8da169439a6122c25dce8b6ca14.tar.bz2
aports-7bdf6c04532bf8da169439a6122c25dce8b6ca14.tar.xz
testing/httpup: new aport
-rw-r--r--testing/httpup/10-getcwd.patch10
-rw-r--r--testing/httpup/APKBUILD49
2 files changed, 59 insertions, 0 deletions
diff --git a/testing/httpup/10-getcwd.patch b/testing/httpup/10-getcwd.patch
new file mode 100644
index 000000000..c3acbeb38
--- /dev/null
+++ b/testing/httpup/10-getcwd.patch
@@ -0,0 +1,10 @@
+--- httpup-0.4.0k.orig/main.cpp
++++ httpup-0.4.0k/main.cpp
+@@ -12,6 +12,7 @@
+ #include <iostream>
+ #include <string>
+ #include <cstdlib>
++#include <unistd.h>
+ using namespace std;
+
+ #include "httpup.h"
diff --git a/testing/httpup/APKBUILD b/testing/httpup/APKBUILD
new file mode 100644
index 000000000..166573fe6
--- /dev/null
+++ b/testing/httpup/APKBUILD
@@ -0,0 +1,49 @@
+# Contributor: z3bra <willy at mailoo dot org>
+# Maintainer:
+pkgname=httpup
+pkgver=0.4.0l
+pkgrel=0
+pkgdesc="One way sync over http (CRUX port)"
+url="http://jw.tks6.net/files/crux/${pkgname}_manual.html"
+arch="all"
+license="GPL"
+depends="curl"
+depends_dev="curl-dev"
+makedepends="$depends_dev"
+subpackages="httpup-doc"
+source="http://jw.tks6.net/files/crux/$pkgname-$pkgver.tar.gz
+ 10-getcwd.patch"
+
+_builddir=$srcdir/$pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+
+ sed -i 's/usr/local/usr' Makefile
+}
+
+build() {
+ cd "$_builddir"
+ make
+
+}
+
+package() {
+ cd "$_builddir"
+
+ make DESTDIR=$pkgdir install
+
+ install -Dm644 COPYING "$pkgdir"/usr/share/licenses/"$pkgname"/COPYING
+}
+
+md5sums="c0e2973f0dbd7655dcbb5e5979ddc199 httpup-0.4.0l.tar.gz
+a158568d4e6fe8cc5d5e3becc1508b31 10-getcwd.patch"
+sha256sums="005079b7d96b23e27dd645492e21f9f93a9a3ebd2ad061069bc038180c04a549 httpup-0.4.0l.tar.gz
+0f6ae9ef93cc835631dae836d3040deaf2f435b8bad6c4b5ea60bce36683b9d2 10-getcwd.patch"
+sha512sums="8e4aab2abc0792de1c9274c2df5ff50e1362d18bcb94fb908e4c9b691de9bb557f39908be015ae436cf4335e54ac4536a7292a304eac4a39a1425d92e36a8fee httpup-0.4.0l.tar.gz
+ba184e443539ddc935041e9cfc075bc8fc16df17329bc626ce6489ae754cee31906fa6339601c2e58333f44ac67fbfdce12b0eff602f83a234c206bfe649f774 10-getcwd.patch"