summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKiyoshi Aman <aphrael@alpinelinux.org>2011-11-26 21:21:34 -0500
committerKiyoshi Aman <aphrael@alpinelinux.org>2011-12-04 22:09:35 -0500
commit8a7826b7be87b7f97ec5b7760a24a8bad420f46e (patch)
tree7ba1c43cc275b002c5e5d3da0e3ef6d3bb35c0e9
parent4288daf5a930d399c5cb9cb41caf03ea69445bf2 (diff)
downloadaports-8a7826b7be87b7f97ec5b7760a24a8bad420f46e.tar.bz2
aports-8a7826b7be87b7f97ec5b7760a24a8bad420f46e.tar.xz
testing/perl-try-tiny: new APKBUILD
-rw-r--r--testing/perl-try-tiny/APKBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/testing/perl-try-tiny/APKBUILD b/testing/perl-try-tiny/APKBUILD
new file mode 100644
index 000000000..c8cad7744
--- /dev/null
+++ b/testing/perl-try-tiny/APKBUILD
@@ -0,0 +1,37 @@
+# Automatically generated by apkbuild-cpan, template 1
+# Contributor: Kiyoshi Aman <kiyoshi.aman@gmail.com>
+# Maintainer: Kiyoshi Aman <kiyoshi.aman@gmail.com>
+pkgname=perl-try-tiny
+_pkgreal=Try-Tiny
+pkgver=0.11
+pkgrel=0
+pkgdesc="unknown"
+url="http://search.cpan.org/dist/Try-Tiny/"
+arch="noarch"
+license="GPL PerlArtistic"
+cpandepends=""
+cpanmakedepends=""
+depends="$cpandepends"
+makedepends="perl-dev $cpanmakedepends"
+subpackages="$pkgname-doc"
+source="http://search.cpan.org/CPAN/authors/id/D/DO/DOY/$_pkgreal-$pkgver.tar.gz"
+
+_builddir="$srcdir/$_pkgreal-$pkgver"
+
+prepare() {
+ cd "$_builddir"
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+}
+
+build() {
+ cd "$_builddir"
+ make && make test
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
+}
+
+md5sums="4d2c8ff385ac3513edf4c042dd0eacbe Try-Tiny-0.11.tar.gz"