summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJeff Bilyk <jbilyk@gmail.com>2010-08-24 21:11:02 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2010-08-25 11:42:52 +0000
commit9cd0653df5eb4f571a92e48322cec98c8fd7f97e (patch)
treecdb309dbf5c4cb5cc8f021ea4297ecf0143b8f54
parentba5e38b280bdaf19211da9e2d6e0b2c76d06ab14 (diff)
downloadaports-9cd0653df5eb4f571a92e48322cec98c8fd7f97e.tar.bz2
aports-9cd0653df5eb4f571a92e48322cec98c8fd7f97e.tar.xz
Fixing dependencies and removing patch
Fixed build and run dependencies. Removed patch since it's not needed.
-rw-r--r--testing/nagios-plugins/APKBUILD30
1 files changed, 12 insertions, 18 deletions
diff --git a/testing/nagios-plugins/APKBUILD b/testing/nagios-plugins/APKBUILD
index e2da9de81..f3cb4b40c 100644
--- a/testing/nagios-plugins/APKBUILD
+++ b/testing/nagios-plugins/APKBUILD
@@ -1,26 +1,16 @@
-# Maintainer: Jeff Bilyk <jbilyk at gmail>
+# Maintainer: Jeff Bilyk <jbilyk@gmail.com>
pkgname=nagios-plugins
pkgver=1.4.15
-pkgrel=0
+pkgrel=1
pkgdesc="Plugins for Nagios to check services on hosts"
url="http://nagiosplugins.org"
license="GPL-2"
-depends="nagios freeradius-client"
-makedepends="uclibc-dev net-snmp-tools openssl-dev fping openldap-dev openssh libpq"
-source="http://downloads.sourceforge.net/nagiosplug/$pkgname-$pkgver.tar.gz
-001-busybox-tweaks.patch"
+depends="nagios fping net-snmp-tools bind-tools"
+makedepends="net-snmp-tools openssl-dev openldap-dev mysql-dev postgresql-dev libpq"
+source="http://downloads.sourceforge.net/nagiosplug/$pkgname-$pkgver.tar.gz"
pkgusers="nagios"
pkggroups="nagios"
-prepare() {
- cd "$srcdir/$pkgname-$pkgver"
- for i in "$srcdir"/*.patch; do
- [ -f "$i" ] || continue
- msg "Applying $i"
- patch -p1 -i "$i" || return 1
- done
-}
-
build() {
cd "$srcdir/$pkgname-$pkgver"
@@ -29,7 +19,12 @@ build() {
--infodir=/usr/share/info \
--bindir=/usr/sbin \
--libexecdir=/usr/lib/nagios/plugins \
- --localstatedir=/var/nagios
+ --localstatedir=/var/nagios \
+ --with-ps-command="/bin/ps" \
+ --with-ps-format="%d %s %s %s" \
+ --with-ps-varlist="&procpid,&procuid,&procpcpu,procprog" \
+ --with-ps-cols=4 \
+ --with-ping-command="/bin/ping -c %d %s"
make all || return 1
}
@@ -38,5 +33,4 @@ package() {
make DESTDIR="$pkgdir" install
}
-md5sums="56abd6ade8aa860b38c4ca4a6ac5ab0d nagios-plugins-1.4.15.tar.gz
-4bb975da57d5e9077968a39a5ab258df 001-busybox-tweaks.patch"
+md5sums="56abd6ade8aa860b38c4ca4a6ac5ab0d nagios-plugins-1.4.15.tar.gz"