summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2011-07-14 17:03:17 +0000
committerWilliam Pitcock <nenolod@dereferenced.org>2011-12-03 14:49:16 -0600
commitc11765fe516b80d1624ad07683df89710562ea56 (patch)
tree951347da82aa797e74f5368933f4d052095ab47c
parent1830490bf97f658d239736bfb2683e6a1b310dfc (diff)
downloadaports-c11765fe516b80d1624ad07683df89710562ea56.tar.bz2
aports-c11765fe516b80d1624ad07683df89710562ea56.tar.xz
Initial APKBUILD for rpmlint
Package description: rpmlint is a tool for checking common errors in RPM packages. It can be used to test individual packages. By default all checks are processed but specific checks can be performed by using command line parameters.
-rw-r--r--testing/rpmlint/APKBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/testing/rpmlint/APKBUILD b/testing/rpmlint/APKBUILD
new file mode 100644
index 000000000..abb06ad9a
--- /dev/null
+++ b/testing/rpmlint/APKBUILD
@@ -0,0 +1,28 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=rpmlint
+pkgver=1.3
+pkgrel=0
+pkgdesc="A tool for checking common errors in RPM packages"
+url="http://rpmlint.zarb.org"
+arch="noarch"
+license="GPL2"
+depends="python"
+depends_dev=""
+makedepends="python-dev"
+install=""
+subpackages="$pkgname-doc"
+source="http://rpmlint.zarb.org/download/$pkgname-$pkgver.tar.xz"
+_builddir="$srcdir"/$pkgname-$pkgver
+
+build() {
+ cd "$_builddir"
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+md5sums="afe1b906776d1ab8148888c25fd31006 rpmlint-1.3.tar.xz"