summaryrefslogtreecommitdiffstats
path: root/main/abuild
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2015-06-08 07:30:21 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2015-06-08 07:31:43 +0000
commita3af123bfbe600c6a78f74f1a2843cb489474d0a (patch)
tree29d9f60913d87cea4192cae847f1bd0847d1b5ed /main/abuild
parent78797c241f56837e1457710e5c8378db05914073 (diff)
downloadaports-a3af123bfbe600c6a78f74f1a2843cb489474d0a.tar.bz2
aports-a3af123bfbe600c6a78f74f1a2843cb489474d0a.tar.xz
main/abuild: fix generation of subpackages
we need clear install_if and provides for subpackages
Diffstat (limited to 'main/abuild')
-rw-r--r--main/abuild/0001-abuild-clear-inherit-provides-and-install_if-for-sub.patch30
-rw-r--r--main/abuild/APKBUILD12
2 files changed, 38 insertions, 4 deletions
diff --git a/main/abuild/0001-abuild-clear-inherit-provides-and-install_if-for-sub.patch b/main/abuild/0001-abuild-clear-inherit-provides-and-install_if-for-sub.patch
new file mode 100644
index 000000000..971cec643
--- /dev/null
+++ b/main/abuild/0001-abuild-clear-inherit-provides-and-install_if-for-sub.patch
@@ -0,0 +1,30 @@
+From 563409ed82164663e08835ed07584337ce601773 Mon Sep 17 00:00:00 2001
+From: Natanael Copa <ncopa@alpinelinux.org>
+Date: Mon, 8 Jun 2015 07:27:23 +0000
+Subject: [PATCH] abuild: clear inherit provides and install_if for subpackages
+
+Unexpected result will happen if subpackages inherits the provides or
+install_if from main package. So we clear them.
+---
+ abuild.in | 5 +++++
+ 1 file changed, 5 insertions(+)
+
+diff --git a/abuild.in b/abuild.in
+index 9e6f43a..cb069f2 100644
+--- a/abuild.in
++++ b/abuild.in
+@@ -947,6 +947,11 @@ archcheck() {
+
+ prepare_package() {
+ msg "Preparing ${subpkgname:+sub}package ${subpkgname:-$pkgname}..."
++ if [ -n "$subpkgname" ]; then
++ # the subpackages should not inherit those
++ provides=""
++ install_if=""
++ fi
+ stripbin
+ prepare_metafiles \
+ && prepare_trace_rpaths \
+--
+2.4.2
+
diff --git a/main/abuild/APKBUILD b/main/abuild/APKBUILD
index 22206a739..6d863f98e 100644
--- a/main/abuild/APKBUILD
+++ b/main/abuild/APKBUILD
@@ -2,7 +2,7 @@
pkgname=abuild
pkgver=2.23.0_rc2
_ver=${pkgver%_git*}
-pkgrel=0
+pkgrel=1
pkgdesc="Script to build Alpine Packages"
url="http://git.alpinelinux.org/cgit/abuild/"
arch="all"
@@ -20,6 +20,7 @@ subpackages="apkbuild-cpan:cpan"
options="suid"
pkggroups="abuild"
source="http://dev.alpinelinux.org/archive/abuild/abuild-$_ver.tar.xz
+ 0001-abuild-clear-inherit-provides-and-install_if-for-sub.patch
"
_builddir="$srcdir/$pkgname-$_ver"
@@ -56,6 +57,9 @@ cpan() {
mv "$pkgdir"/usr/bin/apkbuild-cpan "$subpkgdir"/usr/bin/
}
-md5sums="fd07e1df3a8b3eac403d8b931ffd2cdd abuild-2.23.0_rc2.tar.xz"
-sha256sums="efe6be2a16f55d851bd7125ed3a36f63ea03a546cf4a8cc847cfdb6a801c4bf0 abuild-2.23.0_rc2.tar.xz"
-sha512sums="0b32c7ed6a59a57356a30767869d3e9aaa932aa55dd2982c102821a50a26c9e4a80415d768f24a228e34ecb450bfcbc2f88762fe95c5e218451611c946b6173a abuild-2.23.0_rc2.tar.xz"
+md5sums="fd07e1df3a8b3eac403d8b931ffd2cdd abuild-2.23.0_rc2.tar.xz
+00bdd3304f7d89decc5d4b84e30a10b5 0001-abuild-clear-inherit-provides-and-install_if-for-sub.patch"
+sha256sums="efe6be2a16f55d851bd7125ed3a36f63ea03a546cf4a8cc847cfdb6a801c4bf0 abuild-2.23.0_rc2.tar.xz
+d8744ecb58d86ecb40ee22edbdbcdba1e93cc8e331a9d98641446c08b307873a 0001-abuild-clear-inherit-provides-and-install_if-for-sub.patch"
+sha512sums="0b32c7ed6a59a57356a30767869d3e9aaa932aa55dd2982c102821a50a26c9e4a80415d768f24a228e34ecb450bfcbc2f88762fe95c5e218451611c946b6173a abuild-2.23.0_rc2.tar.xz
+bb55aad137f2cf02f36ce57581a1dc00f6f70f5d4df1c3fcf509772757668abfb3e5e862e40f2b62fad707ec44278f33242f8d37a64473bc72423263df939fea 0001-abuild-clear-inherit-provides-and-install_if-for-sub.patch"