summaryrefslogtreecommitdiffstats
path: root/main/acf-core
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2015-05-07 13:17:39 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2015-05-07 13:18:37 +0000
commit8cdc1d2e3584bff8dae843d263fea4d0927f848e (patch)
treea4dea5140c92215991b4bd13357332645f67f814 /main/acf-core
parente7ede9d57ccf4aa6de45cebf2aa24a216537caec (diff)
downloadaports-8cdc1d2e3584bff8dae843d263fea4d0927f848e.tar.bz2
aports-8cdc1d2e3584bff8dae843d263fea4d0927f848e.tar.xz
main/acf-core: fix shebangs to use proper lua version
ACF does not support multiple parallell lua versions anyways so only require lua 5.2 for now. fixes #4066
Diffstat (limited to 'main/acf-core')
-rw-r--r--main/acf-core/APKBUILD23
1 files changed, 16 insertions, 7 deletions
diff --git a/main/acf-core/APKBUILD b/main/acf-core/APKBUILD
index 9453f163c..82553e525 100644
--- a/main/acf-core/APKBUILD
+++ b/main/acf-core/APKBUILD
@@ -1,23 +1,32 @@
# Contributor: Ted Trask <ttrask01@yahoo.com>
# Maintainer: Ted Trask <ttrask01@yahoo.com>
-_luaversions="5.1 5.2"
+_luaversion="5.2"
pkgname=acf-core
pkgver=0.18.5
-pkgrel=1
+pkgrel=2
pkgdesc="A web-based system administration interface framework"
url="http://git.alpinelinux.org/cgit/acf-core"
arch="noarch"
license="GPL-2"
install="$pkgname.post-upgrade"
-depends="acf-jquery acf-lib acf-skins haserl lua lua-posix lua-md5 lua-json4 lua-subprocess"
+depends="acf-jquery acf-lib acf-skins haserl-lua$_luaversion lua$_luaversion
+ lua$_luaversion-posix lua$_luaversion-md5 lua$_luaversion-json4
+ lua$_luaversion-subprocess"
source="http://dev.alpinelinux.org/archive/$pkgname/$pkgname-$pkgver.tar.xz"
package() {
cd "$srcdir/$pkgname-$pkgver"
- for _i in $_luaversions; do
- sed "s~luadir=.*~luadir=\${prefix}/share/lua/$_i/acf~" -i config.mk
- make DESTDIR="$pkgdir" install
- done
+ sed "s~luadir=.*~luadir=\${prefix}/share/lua/$_i/acf~" -i config.mk \
+ || return 1
+
+ # fix shebang
+ sed -i -e "1s:#!/usr/bin/haserl :#!/usr/bin/haserl-lua$_luaversion :" \
+ www/cgi-bin/acf || return 1
+
+ sed -i -e "1s:#!/usr/bin/lua.*:#!/usr/bin/lua$_luaversion:" \
+ bin/acf-cli || return 1
+
+ make DESTDIR="$pkgdir" install || return 1
mkdir -p "$pkgdir"/etc/acf/skins
}
md5sums="0f097c3b40277f35d89fce7f482ac5f7 acf-core-0.18.5.tar.xz"