summaryrefslogtreecommitdiffstats
path: root/main/apache2
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2011-09-02 12:38:19 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2011-09-02 12:39:11 +0000
commit14d8b3ce0d0c7c58bf88f7497905e44f222409a7 (patch)
treed20ab330d6f108bce0a2c97dca347971cc3cab77 /main/apache2
parent5caa0332aa6bc28a76bed7d5609b4d2238fec11b (diff)
downloadaports-14d8b3ce0d0c7c58bf88f7497905e44f222409a7.tar.bz2
aports-14d8b3ce0d0c7c58bf88f7497905e44f222409a7.tar.xz
main/apache2: security upgrade to 2.2.20 (CVE-2011-3192)
Diffstat (limited to 'main/apache2')
-rw-r--r--main/apache2/APKBUILD46
1 files changed, 23 insertions, 23 deletions
diff --git a/main/apache2/APKBUILD b/main/apache2/APKBUILD
index 4a883adf9..41ee0f264 100644
--- a/main/apache2/APKBUILD
+++ b/main/apache2/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=apache2
-pkgver=2.2.17
-pkgrel=5
+pkgver=2.2.20
+pkgrel=0
pkgdesc="A high performance Unix-based HTTP server"
url="http://httpd.apache.org/"
arch="all"
@@ -9,20 +9,23 @@ license="APACHE"
depends=""
pkgusers="apache"
pkggroups="apache"
-makedepends="openssl-dev zlib-dev apr-util-dev apr-dev pcre-dev
+makedepends="openssl-dev zlib-dev apr-util-dev apr-dev pcre-dev sed
autoconf automake"
subpackages="$pkgname-dev $pkgname-doc $pkgname-utils $pkgname-ssl
$pkgname-ldap"
+# see http://lists.err.no/pipermail/mpm-itk/2011-August/000432.html for
+# the 03-add-mpm-to-build-system.patch
source="http://archive.apache.org/dist/httpd/httpd-$pkgver.tar.bz2
- http://mpm-itk.sesse.net/apache2.2-mpm-itk-2.2.11-02/02-rename-prefork-to-itk.patch
- http://mpm-itk.sesse.net/apache2.2-mpm-itk-2.2.11-02/03-add-mpm-to-build-system.patch
- http://mpm-itk.sesse.net/apache2.2-mpm-itk-2.2.11-02/04-correct-output-makefile-location.patch
- http://mpm-itk.sesse.net/apache2.2-mpm-itk-2.2.11-02/05-add-copyright.patch
- http://mpm-itk.sesse.net/apache2.2-mpm-itk-2.2.11-02/06-hook-just-after-merging-perdir-config.patch
- http://mpm-itk.sesse.net/apache2.2-mpm-itk-2.2.11-02/07-base-functionality.patch
- http://mpm-itk.sesse.net/apache2.2-mpm-itk-2.2.11-02/08-max-clients-per-vhost.patch
- http://mpm-itk.sesse.net/apache2.2-mpm-itk-2.2.11-02/09-capabilities.patch
- http://mpm-itk.sesse.net/apache2.2-mpm-itk-2.2.11-02/10-nice.patch
+ http://mpm-itk.sesse.net/apache2.2-mpm-itk-2.2.17-01/02-rename-prefork-to-itk.patch
+ 03-add-mpm-to-build-system.patch
+ http://mpm-itk.sesse.net/apache2.2-mpm-itk-2.2.17-01/04-correct-output-makefile-location.patch
+ http://mpm-itk.sesse.net/apache2.2-mpm-itk-2.2.17-01/05-add-copyright.patch
+ http://mpm-itk.sesse.net/apache2.2-mpm-itk-2.2.17-01/06-hook-just-after-merging-perdir-config.patch
+ http://mpm-itk.sesse.net/apache2.2-mpm-itk-2.2.17-01/07-base-functionality.patch
+ http://mpm-itk.sesse.net/apache2.2-mpm-itk-2.2.17-01/08-max-clients-per-vhost.patch
+ http://mpm-itk.sesse.net/apache2.2-mpm-itk-2.2.17-01/09-capabilities.patch
+ http://mpm-itk.sesse.net/apache2.2-mpm-itk-2.2.17-01/10-nice.patch
+ http://mpm-itk.sesse.net/apache2.2-mpm-itk-2.2.17-01/11-fix-htaccess-reads-for-persistent-connections.patch
apache2.confd
apache2.logrotate
apache2.initd
@@ -41,15 +44,11 @@ prepare() {
server/mpm/experimental/itk/ || return 1
mv server/mpm/experimental/itk/prefork.c \
server/mpm/experimental/itk/itk.c || return 1
- patch -Np1 -i "$srcdir"/02-rename-prefork-to-itk.patch || return 1
- patch -Np1 -i "$srcdir"/03-add-mpm-to-build-system.patch || return 1
- patch -Np1 -i "$srcdir"/04-correct-output-makefile-location.patch || return 1
- patch -Np1 -i "$srcdir"/05-add-copyright.patch || return 1
- patch -Np1 -i "$srcdir"/06-hook-just-after-merging-perdir-config.patch || return 1
- patch -Np1 -i "$srcdir"/07-base-functionality.patch || return 1
- patch -Np1 -i "$srcdir"/08-max-clients-per-vhost.patch || return 1
- patch -Np1 -i "$srcdir"/09-capabilities.patch || return 1
- patch -Np1 -i "$srcdir"/10-nice.patch || return 1
+ for i in $source; do
+ case $i in
+ *.patch) msg ${i##*/}; patch -p1 -i "$srcdir"/${i##*/} || return 1;;
+ esac
+ done
autoconf || return 1
}
@@ -235,9 +234,9 @@ ldap() {
"$subpkgdir"/etc/apache2/conf.d/ldap.conf || return 1
}
-md5sums="16eadc59ea6b38af33874d300973202e httpd-2.2.17.tar.bz2
+md5sums="1ac251431c8c4285f6b085c1d156bb56 httpd-2.2.20.tar.bz2
db42cfcc18ae1c32aaaff2347e35b79d 02-rename-prefork-to-itk.patch
-131408ad4dc7b18547b4e062e7e495ab 03-add-mpm-to-build-system.patch
+72817bd3eddc56fd886ca4739c536261 03-add-mpm-to-build-system.patch
ee488f391054d528547c3a372faa2aa7 04-correct-output-makefile-location.patch
b202944761b2f0516196488b12504236 05-add-copyright.patch
78fa15f8ca3a284b7d71f942e24e47fb 06-hook-just-after-merging-perdir-config.patch
@@ -245,6 +244,7 @@ d33e39350e987721d50e6fb8e164ab6b 07-base-functionality.patch
9f7a8935f9cabc7b46d0052906634cef 08-max-clients-per-vhost.patch
1b28e3363e1b0d05b738a21e7ddd264f 09-capabilities.patch
d9667fcd2ffecc63e446edd4d6666731 10-nice.patch
+1e5b222edcfbf99a3edc56fcb2074fbe 11-fix-htaccess-reads-for-persistent-connections.patch
e322b5211e49511cac6e40c86af1b1da apache2.confd
75fe4138b98fcffd01b8c8c077b944f3 apache2.logrotate
0261136ff734c3ae8dcf878a46ed5830 apache2.initd