summaryrefslogtreecommitdiffstats
path: root/main/apk-tools
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2013-12-23 16:55:32 +0200
committerTimo Teräs <timo.teras@iki.fi>2013-12-23 16:55:32 +0200
commit9fb4b6e232e2108710e043770c6a22aa23a1870c (patch)
treeff1ac23728332001d199ec92974ba7aaf7bb365c /main/apk-tools
parentd4b7abf8f23aa96021e07ef63ae8a5129faa5ecd (diff)
downloadaports-9fb4b6e232e2108710e043770c6a22aa23a1870c.tar.bz2
aports-9fb4b6e232e2108710e043770c6a22aa23a1870c.tar.xz
main/apk-tools: upstream commit: flush stdout after log message
Diffstat (limited to 'main/apk-tools')
-rw-r--r--main/apk-tools/0001-db-allow-using-cached-packages-with-no-network.patch4
-rw-r--r--main/apk-tools/0002-print-use-stdout-instead-of-stderr-for-logging-and-p.patch5
-rw-r--r--main/apk-tools/0003-print-flush-on-apk_log.patch25
-rw-r--r--main/apk-tools/APKBUILD18
4 files changed, 41 insertions, 11 deletions
diff --git a/main/apk-tools/0001-db-allow-using-cached-packages-with-no-network.patch b/main/apk-tools/0001-db-allow-using-cached-packages-with-no-network.patch
index b638949b8..bb1cc5cbc 100644
--- a/main/apk-tools/0001-db-allow-using-cached-packages-with-no-network.patch
+++ b/main/apk-tools/0001-db-allow-using-cached-packages-with-no-network.patch
@@ -1,7 +1,7 @@
From a6c4103df550ec7c1d99af6a5573c2e3f946b408 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Timo=20Ter=C3=A4s?= <timo.teras@iki.fi>
Date: Wed, 2 Oct 2013 16:06:10 +0300
-Subject: [PATCH] db: allow using cached packages with --no-network
+Subject: [PATCH 1/3] db: allow using cached packages with --no-network
---
src/database.c | 2 +-
@@ -21,5 +21,5 @@ index afe0a8c..9eadb44 100644
return 0;
--
-1.8.4
+1.8.5.1
diff --git a/main/apk-tools/0002-print-use-stdout-instead-of-stderr-for-logging-and-p.patch b/main/apk-tools/0002-print-use-stdout-instead-of-stderr-for-logging-and-p.patch
index 82d7b1347..340ad079e 100644
--- a/main/apk-tools/0002-print-use-stdout-instead-of-stderr-for-logging-and-p.patch
+++ b/main/apk-tools/0002-print-use-stdout-instead-of-stderr-for-logging-and-p.patch
@@ -1,7 +1,8 @@
From 517378721855280d2e23d25d7529e6b9cbae9136 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Timo=20Ter=C3=A4s?= <timo.teras@iki.fi>
Date: Fri, 11 Oct 2013 14:52:34 +0300
-Subject: [PATCH] print: use stdout instead of stderr for logging and progress
+Subject: [PATCH 2/3] print: use stdout instead of stderr for logging and
+ progress
stdout is the proper place for it. this also fixes the progress
bar in musl, which seems to not support using line buffering for
@@ -73,5 +74,5 @@ index 6d00064..aafe2ef 100644
}
--
-1.8.4
+1.8.5.1
diff --git a/main/apk-tools/0003-print-flush-on-apk_log.patch b/main/apk-tools/0003-print-flush-on-apk_log.patch
new file mode 100644
index 000000000..4ef81b57f
--- /dev/null
+++ b/main/apk-tools/0003-print-flush-on-apk_log.patch
@@ -0,0 +1,25 @@
+From 1f8b79347187ab0933b595ded32b69217903037c Mon Sep 17 00:00:00 2001
+From: Natanael Copa <ncopa@alpinelinux.org>
+Date: Thu, 5 Dec 2013 10:58:23 +0100
+Subject: [PATCH 3/3] print: flush on apk_log
+
+Makes it more useful whith pipes.
+---
+ src/print.c | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/src/print.c b/src/print.c
+index aafe2ef..d8b0f3f 100644
+--- a/src/print.c
++++ b/src/print.c
+@@ -149,6 +149,7 @@ void apk_log(const char *prefix, const char *format, ...)
+ vfprintf(stdout, format, va);
+ va_end(va);
+ fprintf(stdout, "\n");
++ fflush(stdout);
+ apk_progress_force = 1;
+ }
+
+--
+1.8.5.1
+
diff --git a/main/apk-tools/APKBUILD b/main/apk-tools/APKBUILD
index 0d09937a6..9b1e82967 100644
--- a/main/apk-tools/APKBUILD
+++ b/main/apk-tools/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=apk-tools
pkgver=2.4.0
-pkgrel=4
+pkgrel=5
pkgdesc="Alpine Package Keeper - package manager for alpine"
subpackages="$pkgname-static"
depends=
@@ -15,6 +15,7 @@ fi
source="http://dev.alpinelinux.org/archive/$pkgname/$pkgname-$pkgver.tar.xz
0001-db-allow-using-cached-packages-with-no-network.patch
0002-print-use-stdout-instead-of-stderr-for-logging-and-p.patch
+ 0003-print-flush-on-apk_log.patch
"
url="http://git.alpinelinux.org/cgit/apk-tools/"
@@ -85,11 +86,14 @@ luaapk() {
}
md5sums="8446c69882d26c8bba38500b6e5577eb apk-tools-2.4.0.tar.xz
-55768a1d97b570eec8940e89f0c0aca3 0001-db-allow-using-cached-packages-with-no-network.patch
-c302063148f3db288394e03c3f75a48b 0002-print-use-stdout-instead-of-stderr-for-logging-and-p.patch"
+1dd6a336016814ef44805f1974961d6b 0001-db-allow-using-cached-packages-with-no-network.patch
+a4d39e02bb7e8cee4c4daf69d684e691 0002-print-use-stdout-instead-of-stderr-for-logging-and-p.patch
+bfc313d60890b25b4eea7f7a8284d815 0003-print-flush-on-apk_log.patch"
sha256sums="ac717df2c512c43e6ea3dd103fcea725ee9135936fe6a177de5021c36735a578 apk-tools-2.4.0.tar.xz
-562f7d5c13ac18500e8e46b3fcae51ca801c34e7565aef712974258b12f2f693 0001-db-allow-using-cached-packages-with-no-network.patch
-8bd1084af5fa8b7257810c896bb93013f660d00db5bf7979fc341de3e627a98b 0002-print-use-stdout-instead-of-stderr-for-logging-and-p.patch"
+92bf5e0d28933a907ddb74b343d322db484be4f909ccb33ac0ec9f320c323fde 0001-db-allow-using-cached-packages-with-no-network.patch
+886ea0b40511c694ef9689bd74e8f861c69d5648c774cad80c622c39a979468e 0002-print-use-stdout-instead-of-stderr-for-logging-and-p.patch
+83cf87712f77d6db296c1775e5cf4b1fb458b732830dc23d9ea46065ccba1260 0003-print-flush-on-apk_log.patch"
sha512sums="97dae73ed34e56349be5027d73720bdb8cf136b6bf0ede6f9fd5199386977d6c718f3593ea0f566aef0c5cdaf59e078f22a4bb1a22132b00dae82dc5927a8279 apk-tools-2.4.0.tar.xz
-9569bdb62447807377a78408aaf47a351e37fbde2f19cf96cc8fe2c1e11520d4e0713309512825f8c08e4f28e68854880e7fa88ba2cb2c39a2fd16044136a876 0001-db-allow-using-cached-packages-with-no-network.patch
-4ea6964e2734e81f80e1e644eb9db5cc4baa0ba3a55e46830bfe33d48c2fef06bf74b1c91b80326b36e8ef1f9013023b4b68f5ed9c0e73a056cef1b6100877f4 0002-print-use-stdout-instead-of-stderr-for-logging-and-p.patch"
+305c669fd98534e8438af656c6be5aa30b23253fa21cf155bc230a7b87f0b85c221f353717c25f2ef84072c34ebcc99ecca54e9cac31139a8f3a636c3bbb5981 0001-db-allow-using-cached-packages-with-no-network.patch
+7f0c9107ff1ba3ab3a5443d53ccb98b47cab3f1b8467457d2c333ece8f92d17c684bfbf9e8db51f91ff759d1ba334708c0190ba0fdeaef85dd922138e2317271 0002-print-use-stdout-instead-of-stderr-for-logging-and-p.patch
+d2ffae4736671db9fa6a60fa04d495d3d31c9998ad099a2f23c0920f0827571fa5ac85ba6522afe16a1d7eba072e25a390fa15d07e7339d0adeb7840af117399 0003-print-flush-on-apk_log.patch"