summaryrefslogtreecommitdiffstats
path: root/main/bwm-ng
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2013-12-03 09:19:22 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2013-12-03 14:39:36 +0000
commit23ed2dc8cd83f3ee1af91f7f7ea3c39b7f3ffe34 (patch)
tree1f4e01a5191de76e0a776c5214469179f3da093c /main/bwm-ng
parented82d2e027a7fcc6321b403647e895196389b002 (diff)
downloadaports-23ed2dc8cd83f3ee1af91f7f7ea3c39b7f3ffe34.tar.bz2
aports-23ed2dc8cd83f3ee1af91f7f7ea3c39b7f3ffe34.tar.xz
main/bwm-ng: fix build with -Wformat -Werror=format-security
Diffstat (limited to 'main/bwm-ng')
-rw-r--r--main/bwm-ng/APKBUILD19
-rw-r--r--main/bwm-ng/format.patch24
2 files changed, 38 insertions, 5 deletions
diff --git a/main/bwm-ng/APKBUILD b/main/bwm-ng/APKBUILD
index 54679d755..9fbb8e9e7 100644
--- a/main/bwm-ng/APKBUILD
+++ b/main/bwm-ng/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=bwm-ng
pkgver=0.6
-pkgrel=4
+pkgrel=5
pkgdesc="A small and simple console-based live bandwidth monitor"
url="http://www.gropp.org/"
arch="all"
@@ -9,11 +9,17 @@ license="GPL2+"
subpackages="$pkgname-doc"
depends=""
makedepends="ncurses-dev"
-source="http://www.gropp.org/$pkgname/$pkgname-$pkgver.tar.gz"
+source="http://www.gropp.org/$pkgname/$pkgname-$pkgver.tar.gz
+ format.patch"
_builddir="$srcdir"/$pkgname-$pkgver
prepare() {
cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
update_config_sub || return 1
}
@@ -36,6 +42,9 @@ package() {
make -j1 DESTDIR="$pkgdir" install || return 1
}
-md5sums="d3a02484fb7946371bfb4e10927cebfb bwm-ng-0.6.tar.gz"
-sha256sums="c1134358e268329d438b0996399003b0f0b966034fb4b5b138761c2f3c62ffdd bwm-ng-0.6.tar.gz"
-sha512sums="7327ec848b0c18d68b2cb0a0ca570bb4d783b534186868d13b453346dbf3ddbcd7e1070803406ff207dc1fd00aa91c06187b0ea7fea28c6c006b44165331c21b bwm-ng-0.6.tar.gz"
+md5sums="d3a02484fb7946371bfb4e10927cebfb bwm-ng-0.6.tar.gz
+a81848e4b31745cc52ee3e890efdd6cf format.patch"
+sha256sums="c1134358e268329d438b0996399003b0f0b966034fb4b5b138761c2f3c62ffdd bwm-ng-0.6.tar.gz
+57d0a2eb25c89df67d9906ede623cc922aa6d28a61810e197740ef993274bea7 format.patch"
+sha512sums="7327ec848b0c18d68b2cb0a0ca570bb4d783b534186868d13b453346dbf3ddbcd7e1070803406ff207dc1fd00aa91c06187b0ea7fea28c6c006b44165331c21b bwm-ng-0.6.tar.gz
+1b662eeed76f5cb7291e0ab0399a0e8fc862eac036856ce03b23b6c220d6eb544834b4eb4973f570c1b8b70df8fd9f86ae4f7fd7d80aff01386fd52bf004e701 format.patch"
diff --git a/main/bwm-ng/format.patch b/main/bwm-ng/format.patch
new file mode 100644
index 000000000..cf5194101
--- /dev/null
+++ b/main/bwm-ng/format.patch
@@ -0,0 +1,24 @@
+diff --git a/src/output.c b/src/output.c
+index e9b1442..c2a6b6e 100644
+--- a/src/output.c
++++ b/src/output.c
+@@ -223,8 +223,8 @@ int print_header(int option) {
+ fprintf(tmp_out_file,"<title>bwm-ng stats</title>\n</head>\n<body>\n");
+ }
+ fprintf(tmp_out_file,"<div class=\"bwm-ng-header\">bwm-ng bwm-ng v" VERSION " (refresh %is); input: ",html_refresh);
+- fprintf(tmp_out_file,input2str());
+- fprintf(tmp_out_file,show_all_if2str());
++ fprintf(tmp_out_file,"%s",input2str());
++ fprintf(tmp_out_file,"%s",show_all_if2str());
+ fprintf(tmp_out_file,"</div><table class=\"bwm-ng-output\">");
+ fprintf(tmp_out_file,"<tr class=\"bwm-ng-head\"><td class=\"bwm-ng-name\">Interface</td><td>Rx</td><td>Tx</td><td>Total</td></tr>");
+ break;
+@@ -234,7 +234,7 @@ int print_header(int option) {
+ if (output_method==PLAIN_OUT && ansi_output) printf("\033[1;2H");
+ printf("bwm-ng v" VERSION " (delay %2.3fs); ",(float)delay/1000);
+ if (output_method==PLAIN_OUT) printf("press 'ctrl-c' to end this%s",(ansi_output ? "\033[2;2H" : "")); else printf("input: ");
+- printf(input2str());
++ printf("%s",input2str());
+ printf("%s\n",show_all_if2str());
+ if (output_method==PLAIN_OUT) {
+ if (ansi_output)