summaryrefslogtreecommitdiffstats
path: root/main/claws-mail
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2015-04-30 14:17:29 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2015-04-30 14:17:29 +0000
commit8d85a4bc792065ba8a2247c11b917046d38c0fb9 (patch)
treeca11f8dccee6072f8078f57ce36ce2d473705d3a /main/claws-mail
parent90a14cb6c868f230f15201eb85093408380feb70 (diff)
downloadaports-8d85a4bc792065ba8a2247c11b917046d38c0fb9.tar.bz2
aports-8d85a4bc792065ba8a2247c11b917046d38c0fb9.tar.xz
main/claws-mail: fix for rssyl
Diffstat (limited to 'main/claws-mail')
-rw-r--r--main/claws-mail/APKBUILD12
-rw-r--r--main/claws-mail/claws.git-72510f27b10889e119b42804835e8beaf70bc18d.patch30
2 files changed, 38 insertions, 4 deletions
diff --git a/main/claws-mail/APKBUILD b/main/claws-mail/APKBUILD
index 864e80fd8..52c8614c3 100644
--- a/main/claws-mail/APKBUILD
+++ b/main/claws-mail/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=claws-mail
pkgver=3.11.1
-pkgrel=1
+pkgrel=2
pkgdesc="A GTK+ based e-mail client."
url="http://www.claws-mail.org"
arch="all"
@@ -38,6 +38,7 @@ makedepends="gtk+-dev openssl-dev startup-notification-dev enchant-dev
depends="aspell-en"
install=
source="http://downloads.sourceforge.net/project/claws-mail/Claws%20Mail/$pkgver/claws-mail-$pkgver.tar.xz
+ claws.git-72510f27b10889e119b42804835e8beaf70bc18d.patch
"
_builddir="$srcdir"/$pkgname-$pkgver
@@ -187,6 +188,9 @@ _vcalendar () {
}
-md5sums="4cbf9b53c4cf691e093bd98efc0dbb63 claws-mail-3.11.1.tar.xz"
-sha256sums="d72381b6c9f872638cae2c208925e19bd5d4a9476bb9049742f1ba27c3efd133 claws-mail-3.11.1.tar.xz"
-sha512sums="ae4f0d4299647e201e94111a6eb26cce1d6a72045c317b879a07847cfcc75c35dfdf571f2826d365800586f5798131ce95985f746f7dbdd878f3766370ab3570 claws-mail-3.11.1.tar.xz"
+md5sums="4cbf9b53c4cf691e093bd98efc0dbb63 claws-mail-3.11.1.tar.xz
+02c242490c4b99dd5387332566ffe3bc claws.git-72510f27b10889e119b42804835e8beaf70bc18d.patch"
+sha256sums="d72381b6c9f872638cae2c208925e19bd5d4a9476bb9049742f1ba27c3efd133 claws-mail-3.11.1.tar.xz
+8ab7a747ab483363bb49fb0e42094e8513f5ac9575d71a6841898b073f89f3b9 claws.git-72510f27b10889e119b42804835e8beaf70bc18d.patch"
+sha512sums="ae4f0d4299647e201e94111a6eb26cce1d6a72045c317b879a07847cfcc75c35dfdf571f2826d365800586f5798131ce95985f746f7dbdd878f3766370ab3570 claws-mail-3.11.1.tar.xz
+67add41b754cb3b0d08928b5c4cdea26bd271b2dd4303f22d641432f1d580308aadf5b7ae436c2451ed6649bcfec66f3f6dbc69e4655ac09aecc7ba43da054da claws.git-72510f27b10889e119b42804835e8beaf70bc18d.patch"
diff --git a/main/claws-mail/claws.git-72510f27b10889e119b42804835e8beaf70bc18d.patch b/main/claws-mail/claws.git-72510f27b10889e119b42804835e8beaf70bc18d.patch
new file mode 100644
index 000000000..b16e59d47
--- /dev/null
+++ b/main/claws-mail/claws.git-72510f27b10889e119b42804835e8beaf70bc18d.patch
@@ -0,0 +1,30 @@
+From 72510f27b10889e119b42804835e8beaf70bc18d Mon Sep 17 00:00:00 2001
+From: Andrej Kacian <ticho@claws-mail.org>
+Date: Thu, 8 Jan 2015 22:51:04 +0100
+Subject: [PATCH] RSSyl: Day-of-week name in RFC822 timestamps is optional.
+
+---
+ src/plugins/rssyl/libfeed/date.c | 7 +++++--
+ 1 file changed, 5 insertions(+), 2 deletions(-)
+
+diff --git a/src/plugins/rssyl/libfeed/date.c b/src/plugins/rssyl/libfeed/date.c
+index c37756d..92f5a86 100644
+--- a/src/plugins/rssyl/libfeed/date.c
++++ b/src/plugins/rssyl/libfeed/date.c
+@@ -132,8 +132,11 @@ time_t parseRFC822Date(gchar *date)
+ if (c != NULL)
+ setlocale(LC_TIME, "C");
+
+- if (!strptime(date, "%a, %d %b %Y %H:%M:%S %Z", &t) &&
+- !strptime(date, "%a, %d %b %Y %H:%M %Z", &t)) {
++ if (date != NULL &&
++ !strptime(date, "%a, %d %b %Y %H:%M:%S %Z", &t) &&
++ !strptime(date, "%a, %d %b %Y %H:%M %Z", &t) &&
++ !strptime(date, "%d %b %Y %H:%M:%S %Z", &t) &&
++ !strptime(date, "%d %b %Y %H:%M %Z", &t)) {
+ g_warning("Invalid RFC822 date!\n");
+ if (c != NULL)
+ setlocale(LC_TIME, c);
+--
+1.7.10.4
+