summaryrefslogtreecommitdiffstats
path: root/main/claws-mail
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2010-01-25 16:43:57 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2010-01-25 16:43:57 +0000
commit9526ee659401dee7160f35cb62ded2779bcbbc99 (patch)
tree812ad73bde9c84dcc02a3acbc5db576369ca314a /main/claws-mail
parent05e09c1126a898b6d0af491fef0401bf53e297f8 (diff)
downloadaports-9526ee659401dee7160f35cb62ded2779bcbbc99.tar.bz2
aports-9526ee659401dee7160f35cb62ded2779bcbbc99.tar.xz
merged x11 repository into main
ref #255
Diffstat (limited to 'main/claws-mail')
-rw-r--r--main/claws-mail/APKBUILD50
-rw-r--r--main/claws-mail/libc-version.patch22
2 files changed, 72 insertions, 0 deletions
diff --git a/main/claws-mail/APKBUILD b/main/claws-mail/APKBUILD
new file mode 100644
index 000000000..5d133d744
--- /dev/null
+++ b/main/claws-mail/APKBUILD
@@ -0,0 +1,50 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=claws-mail
+pkgver=3.7.4
+pkgrel=0
+pkgdesc="A GTK+ based e-mail client."
+url="http://www.claws-mail.org"
+license="GPL3"
+subpackages="$pkgname-dev $pkgname-doc"
+makedepends="gtk+-dev openssl-dev startup-notification-dev enchant-dev
+ libsm-dev gnutls-dev curl-dev dbus-glib-dev libetpan-dev openldap-dev"
+depends=
+# gpgme-dev libetpan-dev
+#pilot-link>=0.12.3-5
+install= #claws-mail.install
+source="http://downloads.sourceforge.net/sourceforge/sylpheed-claws/$pkgname-$pkgver.tar.bz2
+ libc-version.patch"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+prepare() {
+ cd "$_builddir"
+ patch -p1 -i ../libc-version.patch || return 1
+}
+
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ --disable-static \
+ --enable-enchant \
+ --enable-gnutls \
+ --enable-ldap \
+ --disable-dillo-viewer-plugin \
+ --enable-crash-dialog \
+ --enable-pgpmime-plugin \
+ --enable-spamassassin-plugin \
+ --enable-bogofilter-plugin \
+ --disable-jpilot
+ make || return 1
+ cd tools
+ make
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install
+ find tools -maxdepth 1 -type f -and -perm /111 -or -name '*.conf' | while read i; do
+ install -D -m755 ${i} "$pkgdir"/usr/lib/claws-mail/tools/${i}
+ done
+}
+md5sums="aa6c8b9177bc2bc506470821ee2afbb2 claws-mail-3.7.4.tar.bz2
+f3416743b5d8ff97b5a3cc2f7efc2dc1 libc-version.patch"
diff --git a/main/claws-mail/libc-version.patch b/main/claws-mail/libc-version.patch
new file mode 100644
index 000000000..c55c007ba
--- /dev/null
+++ b/main/claws-mail/libc-version.patch
@@ -0,0 +1,22 @@
+--- a/src/crash.c.orig 2009-09-05 22:12:33.000000000 +0000
++++ b/src/crash.c 2009-09-05 22:14:34.000000000 +0000
+@@ -42,7 +42,7 @@
+ # include <sys/utsname.h>
+ #endif
+
+-#if defined(__GNU_LIBRARY__)
++#if defined(__GNU_LIBRARY__) && !defined(__UCLIBC__)
+ # include <gnu/libc-version.h>
+ #endif
+
+@@ -446,7 +446,9 @@
+ */
+ static const gchar *get_lib_version(void)
+ {
+-#if defined(__GNU_LIBRARY__)
++#if defined(__UCLIBC__)
++ return g_strdup_printf("uClibc");
++#elif defined(__GNU_LIBRARY__)
+ return g_strdup_printf("GNU libc %s", gnu_get_libc_version());
+ #else
+ return g_strdup(_("Unknown"));