summaryrefslogtreecommitdiffstats
path: root/main/collectd
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2013-10-14 19:28:32 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2013-10-14 19:28:32 +0000
commit4699565dcdabdb6ba01ed150d52bfdd61a12ffe4 (patch)
tree1f1fc2fdb5868c28b7aa4bf34b90ffa0b46e16ce /main/collectd
parent9f32031184b4752b675ed236615b7c4fe96c5182 (diff)
downloadaports-4699565dcdabdb6ba01ed150d52bfdd61a12ffe4.tar.bz2
aports-4699565dcdabdb6ba01ed150d52bfdd61a12ffe4.tar.xz
main/collectd: split out python, iptables, bind and ascent plugins
and fix rrdtool plugin
Diffstat (limited to 'main/collectd')
-rw-r--r--main/collectd/APKBUILD16
1 files changed, 11 insertions, 5 deletions
diff --git a/main/collectd/APKBUILD b/main/collectd/APKBUILD
index 65441b910..cdb8239a6 100644
--- a/main/collectd/APKBUILD
+++ b/main/collectd/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=collectd
pkgver=5.4.0
-pkgrel=0
+pkgrel=1
pkgdesc="The system statistics collection daemon"
url="http://collectd.org"
arch="all"
@@ -14,7 +14,9 @@ install=""
subpackages="$pkgname-dev $pkgname-doc $pkgname-perl $pkgname-snmp
$pkgname-curl:_curl
$pkgname-write_http $pkgname-nginx $pkgname-apache $pkgname-postgresql
- $pkgname-mysql $pkgname-network $pkgname-rrdtool $pkgname-sensors"
+ $pkgname-mysql $pkgname-network $pkgname-rrdtool $pkgname-sensors
+ $pkgname-python:_python $pkgname-iptables:_ipt $pkgname-bind
+ $pkgname-ascent"
source="http://collectd.org/files/collectd-$pkgver.tar.bz2
collectd.initd"
@@ -84,15 +86,19 @@ _plugin() {
}
snmp() { _plugin snmp; }
-_curl() { _plugin curl; }
-write_http() { _plugin write_http; }
+_curl() { _plugin 'curl*'; }
+write_http() { _plugin write_http; }
nginx() { _plugin nginx; }
apache() { _plugin apache; }
postgresql() { _plugin postgresql; }
mysql() { _plugin mysql; }
network() { _plugin network; }
-rrdtool() { _plugin rrdtool; }
+rrdtool() { _plugin 'rrd*'; }
sensors() { _plugin sensors; }
+_python() { _plugin python; }
+_ipt() { _plugin iptables; }
+bind() { _plugin bind; }
+ascent() { _plugin ascent; }
md5sums="bbcc8d0dd466d1ec7d8311646d5bddd8 collectd-5.4.0.tar.bz2
13a36ae2f92634b5619ab94224e1b77d collectd.initd"