summaryrefslogtreecommitdiffstats
path: root/main/crconf
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2015-04-10 10:56:22 +0300
committerTimo Teräs <timo.teras@iki.fi>2015-04-10 10:58:04 +0300
commitb692a2a1544322a47419945a9d0178f4de990199 (patch)
tree04478a85e629e7f594870568e72dc63f3206f966 /main/crconf
parent54b2aa9e1826c1fde073cebe92520b56b18cdfc6 (diff)
downloadaports-b692a2a1544322a47419945a9d0178f4de990199.tar.bz2
aports-b692a2a1544322a47419945a9d0178f4de990199.tar.xz
main/crconf: new aport
Linux crypto layer configuraton tool http://sourceforge.net/projects/crconf/
Diffstat (limited to 'main/crconf')
-rw-r--r--main/crconf/APKBUILD40
1 files changed, 40 insertions, 0 deletions
diff --git a/main/crconf/APKBUILD b/main/crconf/APKBUILD
new file mode 100644
index 000000000..34503be6c
--- /dev/null
+++ b/main/crconf/APKBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Timo Teräs <timo.teras@iki.fi>
+pkgname=crconf
+pkgver=0_pre2
+_realver=pre2
+pkgrel=0
+pkgdesc="Linux crypto layer configuration tool"
+url="http://sourceforge.net/projects/crconf/"
+arch="all"
+license="GPLv2"
+depends=""
+makedepends=""
+subpackages=""
+source="http://downloads.sourceforge.net/project/crconf/crconf-$_realver.tar.gz
+ "
+
+_builddir="$srcdir"/$pkgname-$_realver
+
+prepare() {
+ cd $_builddir
+
+ for i in $source; do
+ case $i in
+ *.patch) msg "$i"; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd $_builddir
+ make || return 1
+}
+
+package() {
+ cd $_builddir
+ make -j1 DESTDIR="$pkgdir" install
+}
+
+md5sums="4b96e3fbd570d694ea25659a79a6db5c crconf-pre2.tar.gz"
+sha256sums="15d39b599acda93a50f473190e702d593ba13613b6ed31711f3584b5726b81b8 crconf-pre2.tar.gz"
+sha512sums="e4526626c71391968beafaf606bc477849ed11007bcfe4dd9b056bdbd08d19dce41b18418693fd5d2fab29f618e3fdad3ec4f4f2ea269207443e94e7552b4daa crconf-pre2.tar.gz"