summaryrefslogtreecommitdiffstats
path: root/main/cups-filters
diff options
context:
space:
mode:
authorIsaac Dunham <ibid.ag@gmail.com>2014-06-30 14:51:41 -0700
committerNatanael Copa <ncopa@alpinelinux.org>2014-07-02 07:21:00 +0000
commitd1e6066a870aa6a04f711ce553ed05c257f65b6f (patch)
tree2aaabb18598d5f0d576dbde84f3304de68463262 /main/cups-filters
parent244246ec2cb6d5916c566a605189c0cde641bae7 (diff)
downloadaports-d1e6066a870aa6a04f711ce553ed05c257f65b6f.tar.bz2
aports-d1e6066a870aa6a04f711ce553ed05c257f65b6f.tar.xz
main/cups-filters: fix text file printing
ttf-freefont is needed for text printing to work. pdf.UTF-8 symlink is needed; pdf.utf-8 isn't good enough now.
Diffstat (limited to 'main/cups-filters')
-rw-r--r--main/cups-filters/APKBUILD9
1 files changed, 7 insertions, 2 deletions
diff --git a/main/cups-filters/APKBUILD b/main/cups-filters/APKBUILD
index 697f876a4..f87f00801 100644
--- a/main/cups-filters/APKBUILD
+++ b/main/cups-filters/APKBUILD
@@ -1,13 +1,15 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=cups-filters
pkgver=1.0.54
-pkgrel=0
+pkgrel=1
pkgdesc="OpenPrinting CUPS filters and backends"
url="http://www.linuxfoundation.org/collaborate/workgroups/openprinting/pdf_as_standard_print_job_format"
arch="all"
license="GPLv2 and GPLv2+ and GPLv3 and MIT"
# textonly is a bash script
-depends="poppler-utils bc bash"
+# texttops/textopdf need FreeMono from ttf-freefont
+# for text printing to work
+depends="poppler-utils bc bash ttf-freefont"
depends_dev=""
makedepends="$depends_dev cups-dev libjpeg-turbo-dev poppler-dev zlib-dev
libpng-dev tiff-dev lcms-dev freetype-dev ghostscript-dev fontconfig-dev
@@ -49,6 +51,9 @@ build() {
package() {
cd "$_builddir"
make -j1 DESTDIR="$pkgdir" install || return 1
+ #the pdf.utf-8 symlink isn't quite good enough
+ cd "$pkgdir"/usr/share/cups/charsets && \
+ ln -s pdf.utf-8.simple pdf.UTF-8 || return 1
rm -f "$pkgdir"/usr/lib/*.la
}